Problem running openni_launch.launch --- Failed to load nodelet [/camera/driver] of type [openni_camera/driver]: Could not find library corresponding to plugin openni_camera/driver. [closed]

asked 2014-03-03 18:54:01 -0500

Veerachart gravatar image

updated 2016-10-24 09:05:32 -0500

ngrennan gravatar image

Hi,

I tried to follow the Quick Start Guide of openni_launch. As I am using Ubuntu 13.10, I have to install ROS (hydro) from source, not by apt-get, and it is the same way for other packages.

So, I installed openni_launch and openni_camera by cloning from github into my workspace, catkin_make it, and source the bash file. Then I ran

roslaunch openni_launch openni_launch.launch

And the following red texts appeared:

[ERROR] [1393915524.708745003]: Failed to load nodelet [/camera/driver] of type [openni_camera/driver]: Could not find library corresponding to plugin openni_camera/driver. Make sure the plugin description XML file has the correct name of the library and that the library actually exists.\\[FATAL] [1393915524.710317875]: Service call failed!

...

[camera/driver-2] process has died [pid 10661, exit code 255, cmd /home/veerachart/Research/ROS/ros_catkin_ws/install_isolated/lib/nodelet/nodelet load openni_camera/driver camera_nodelet_manager --no-bond ir:=ir rgb:=rgb depth:=depth depth_registered:=depth_registered projector:=projector __name:=driver __log:=/home/veerachart/.ros/log/d7834e80-a361-11e3-9fd2-648099777478/camera-driver-2.log].\\log file: /home/veerachart/.ros/log/d7834e80-a361-11e3-9fd2-648099777478/camera-driver-2*.log

(Full output here)

When trying to use Rviz to visualize, nothing appeared. It said "No image received." image_view also showed nothing,

Anyone has had this kind of problem? Is it related to the fact that I installed ROS from source, and I created another workspace separated from the one that I used to install it?

My system: Ubuntu 13.10 64-bit, ros-hydro installed from source, Kinect for Xbox (but I have tried with Kinect for Windows too)

Thank you,

Veerachart

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by tfoote
close date 2018-01-30 17:43:56.949477

Comments

Well, I forgot to add the source command in my .bashrc. After sourcing the setup.bash file the first error becomes [ERROR] [1394169434.884048329]: Failed to load nodelet [/camera/driver] of type [openni_camera/driver]: Failed to load library /home/veerachart/Research/catkin_ws/devel/lib//libopenni_nodelet.so. Make sure that you are calling the PLUGINLIB_EXPORT_CLASS macro in the library code, and that names are consistent between this macro and your XML. Error string: Could not load library (Poco exception = /home/veerachart/Research/catkin_ws/devel/lib//libopenni_nodelet.so: undefined symbol: _ZTIN7log4cxx7helpers13ObjectPtrBaseE)

Veerachart gravatar imageVeerachart ( 2014-03-06 17:20:09 -0500 )edit

when you type "lsusb" you can see your kinect? You are using an USB3.0 Port? Only the camera/driver process died or a few more? Maybe you can try "killall -s 9 XnSensorServer" and then start the driver again. If it doesnt work, please try another USB port....

patrickl gravatar imagepatrickl ( 2014-03-07 01:40:06 -0500 )edit

Hi patrickl. "lsusb" show that Kinect is connected to the computer. I'm using USB3.0 port, but I have tried switching to USB2.0 from BIOS, and the same thing happened. Only camera/driver died; the rest started, and "rostopic list" still shows a lot of camera topics. I'll try the rest of you suggestion on Monday, but anyway I don't have a USB2.0 on my computer.

Veerachart gravatar imageVeerachart ( 2014-03-07 02:08:04 -0500 )edit

Maybe a usb2.0/esata combo? it would be the easiest way. If not, you can maybe find a solution here: http://answers.ros.org/question/53089/ubuntu-1210-groovy-openni-usb30-working/ or http://answers.ros.org/question/9179/kinect-and-usb-30/

patrickl gravatar imagepatrickl ( 2014-03-07 02:27:45 -0500 )edit

I tried the "killall" command, and it said: "XnSensorServer: no process found". Changing port also didn't help. I don't understand about usb2.0/esata that you mentioned. The other 2 links seem unrelevant to my problem. One more thing, I had been using the same Kinect on this notebook on USB3.0 before installing ROS, with libfreenect library.

Veerachart gravatar imageVeerachart ( 2014-03-09 19:13:15 -0500 )edit

One thing that I notice is that in the error, there are 2 "/" in the address "/home/veerachart/Research/catkin_ws/devel/lib//libopenni_nodelet.so". Would that cause the problem. Anyway I haven't changed anything from the original package, even tried removing the library and download it & make again.

Veerachart gravatar imageVeerachart ( 2014-03-09 19:18:22 -0500 )edit

a installation of the ros-groovy-openni-launch normally includes all needed libs and drivers.... your laptop hast maybe something like this? http://en.wikipedia.org/wiki/ESATAp

patrickl gravatar imagepatrickl ( 2014-03-09 23:32:57 -0500 )edit

eSATA is not written near my USB port, only SS for USB3.0 symbol.

Veerachart gravatar imageVeerachart ( 2014-03-09 23:57:14 -0500 )edit