ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

CMake Error "tf" while building ar_track_alvar

asked 2014-09-30 07:08:00 -0500

rookie gravatar image

updated 2014-10-01 01:11:35 -0500

I am trying to build the AR tag detector package ar_track_alavar on Odroid U3 running ROS hydro on Lubuntu 13.04 Running catkin_make after cloning the package gives me the following error :

CMake Error at /opt/ros/hydro/share/catkin/cmake/catkinConfig.cmake:75 (find_package): Could not find a package configuration file provided by "tf" with any of the following names:


Add the installation prefix of "tf" to CMAKE_PREFIX_PATH or set "tf_DIR" to a directory containing one of the above files. If "tf" provides a separate development package or SDK, be sure it has been installed. Call Stack (most recent call first): ar_track_alvar/CMakeLists.txt:10 (find_package)

-- Configuring incomplete, errors occurred! Invoking "cmake" failed

Can someone please explain how to resolve this error?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2014-09-30 11:27:42 -0500

Dirk Thomas gravatar image

This is a standard CMake error message telling you that it can not find tf. You need to install the missing dependencies either using rosdep or by installing the missing packages manually (in this case ros-hydro-tf).

edit flag offensive delete link more


Thanks.. i installed this package and catkin_make worked ! But I faced a weird problem that it gets stuck at around 22% and my Odroid hangs..probably the CPU usage is shooting up, something that has never happened before..I tried this twice but with the same result :/

rookie gravatar image rookie  ( 2014-10-02 00:48:32 -0500 )edit

Check out this Odroid image

spottybadrabbit gravatar image spottybadrabbit  ( 2016-08-10 12:27:17 -0500 )edit

Question Tools

1 follower


Asked: 2014-09-30 07:08:00 -0500

Seen: 5,853 times

Last updated: Oct 01 '14