Ask Your Question
0

usarsim_inf not working with teleop_twist_keyboard [closed]

asked 2014-09-28 12:52:58 -0600

Aarif gravatar image

updated 2014-10-11 12:13:32 -0600

hello, I am trying to navigate a robot(P3AT) spawned in usarsim environment using keyboard from another computer where ros is installed, but its not working, please help me out, i tried a lot but can't figure out the mistake.

I am following these steps given below:-

  1. In one terminal Run $roscore
  2. Spawn a Robot in usarsim, for this i am following these steps:-

    A. Start usarsim, which is in another windows machine.

    B. In another ros terminal Run the the following command:

    $roslaunch usarsim_inf usarsim.launch
    

    This spawns a P3AT robot in usarsim environment. and following output appears:-

    ... logging to /home/cr-lab-tu/.ros/log/e3f28b38-4729-11e4-959a-2c27d7efa01b/roslaunch-crlabtu-HP-Z800-Workstation-3277.log
    Checking log directory for disk usage. This may take awhile.
    Press Ctrl-C to interrupt
    Done checking log file disk usage. Usage is <1GB.
    
    started roslaunch server http://crlabtu-HP-Z800-Workstation:39055/
    
    SUMMARY
    ========
    
    PARAMETERS
       * /rosdistro
       * /rosversion
       * /usarsim/hostname
       * /usarsim/odomSensor
       * /usarsim/port
       * /usarsim/robotType
       * /usarsim/startPosition
    
    NODES
      /
        RosSim (usarsim_inf/usarsim_node)
    
    ROS_MASTER_URI=http://localhost:11311
    
    core service [/rosout] found
    process[RosSim-1]: started with pid [3297]
    [ERROR] [1411920693.631497443]: Unknown conf type Camera
    
  3. Then i run teleop_twist_keyboard using the following command:-

    $ rosrun teleop_twist_keyboard teleop_twist_keyboard.py
    
  4. Run the slam_gmapping node, using the following command:-

    $ rosrun gmapping slam_gmapping scan:=lms200 _odom_frame:=odom
    
  5. Now i can press the keyboard keys to navigate the Robot in usarsim environment, but when i do it nothing happens and following error gets added each time when i press the keyboard keys to navigate the robot, on the terminal where i launch the usarsim.launch file. errors are given below:-

    [ERROR] [1411920792.568087748]: usarsimInf::peerMsg: not handling type SW_SEN_ENCODER
    
  6. I have run $rosrun rqt_graph rqt_graph and i found the following rqt_graph-click to view
  7. Then i've run the follownig command:

    $ rostopic echo /cmd_vel
    

    This generated following graph click to view

    Please help me to figure out the error if any or correct way to navigate through Keyboard.

    Note: I am using ROS-Fuerte on UBUNTU 10.04 LTS

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Aarif
close date 2014-10-14 12:50:34.859271

Comments

You've already asked this before. Please update your old question instead of asking a new question.

ahendrix gravatar imageahendrix ( 2014-10-06 10:43:15 -0600 )edit

hello @ahendrix, in the old question i asked regarding teleop_twist_keyboard's issue with executive_usarsim package,

but in this question i asked that usarsim_inf not working with teleop_twist_keyboard.

so they are not the same question because they are dealing with different package.

Aarif gravatar imageAarif ( 2014-10-06 11:46:18 -0600 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2014-10-13 07:29:24 -0600

updated 2016-10-04 11:33:57 -0600

ahendrix gravatar image

Please type following commands on the terminal window of PC2.

terminal-1:
    $ echo “source /opt/ros/fuerte/setup.bash” >> ~/.bashrc
    $ . ~/.bashrc
    $ sudo apt-get install python-rosinstall python-rosdep ros-fuerte-brown-remotelab ros-fuerte-control ros-fuerte-common-msgs ros-fuerte-slam-gmapping ros-fuerte-hector-slam
    $ rosws init ~/fuerte_workspace /opt/ros/fuerte
    $ echo “source ~/fuerte_workspace/setup.bash” >> ~/.bashrc
    $ mkdir ~/fuerte_workspace/sandbox
    $ source ~/fuerte_workspace/setup.bash
    $ rosws set ~/fuerte_workspace/sandbox
    $ source ~/fuerte_workspace/setup.bash
    $ roscd
    $ cd sandbox
    $ git clone git://git.assembla.com/usarsim.git
        (Under the proxy, try “git clone http://git.assembla.com/usarsim.git&#8221")
    $ rosmake usarsim_inf

    At this point if making usarsim_inf is successful, then use these steps,

    terminal-1: $ roscore
    terminal-2: $ export ROS_PACKAGE_PATH=$ROS_PACKAGE_PATH:`pwd`
                    $ roslaunch usarsim_inf usarsim.launch
    terminal-3: $ rosrun teleop_twist_keyboard teleop_twist_keyboard.py

now navigate using key. It works.

edit flag offensive delete link more

Comments

I think 'PWD' should use backticks instead of single quotes.

gvdhoorn gravatar imagegvdhoorn ( 2014-10-13 08:45:45 -0600 )edit

Thank you sooo much @sumant it worked... :)

Aarif gravatar imageAarif ( 2014-10-14 12:45:21 -0600 )edit

yes @gvdhoorn it is

export ROS_PACKAGE_PATH=$ROS_PACKAGE_PATH:`pwd`
sumant gravatar imagesumant ( 2014-10-18 05:45:34 -0600 )edit

Now one year later, i on a new PC , i am facing the same problem.

 [ERROR] [1475649575.941420195]: Unknown conf type Camera

please help. The above answer do not work for me.

I would like to know the reason behind.

sumant gravatar imagesumant ( 2016-10-05 01:41:26 -0600 )edit

Question Tools

1 follower

Stats

Asked: 2014-09-28 12:52:58 -0600

Seen: 467 times

Last updated: Oct 04 '16