teleop_twist_keyboard not working with executive_usarsim

asked 2014-09-23 14:07:27 -0600

Aarif gravatar image

updated 2014-09-26 12:16:44 -0600

hello,

i want to navigate P3AT robot spawned in usarsim through teleop_twist_keyboard package.

I have connected ros to usarsim using executive_usarsim package and spawned the P3AT robot in usarsim, but when i run teleop_twist_keyboard and presses keys to move the robot, nothing happens. please help me out.

i am following steps mentioned below:-

  1. Start USARSim

  2. Run $roscore

  3. run executive_usarsim package using the following command.

    ($rosrun executive_usarsim usarsim_manager.py)

    this command opens a connect USARSIM UI through which i can connect ROS to the USARSim and can spawn a P3AT robot in USARSim

  4. Run the teleop_twist_key node

    now you can press the navigation keys to move the Robot, but when i do this nothing happens.

  5. Then i run $rosrun rqt_graph rqt_graph, the following rqt graph appears: Click to view rqt_graph

  6. then i have run $ rostopic echo /executive_usarsim/status, following graph appeared: Click to view graph

  7. by running $ rostopic list, following output appeared:-

    cr-lab-tu@crlabtu-HP-Z800-Workstation:~$ rostopic list

    **/cmd_vel

    /executive_usarsim/status

    /rosout

    /rosout_agg

    cr-lab-tu@crlabtu-HP-Z800-Workstation:~$**

    please help, i can't figure out how to fix it.

    note:- I am using UBUNTU 12.04 LTS and ROS-Fuerte

edit retag flag offensive close merge delete

Comments

Can you run rqt_graph and confirm that the cmd_vel topic is connected?

ahendrix gravatar imageahendrix ( 2014-09-23 14:09:11 -0600 )edit

hello @ahendrix

i have run the $rosrun rqt_graph rqt_graph and i found cmd_val is not connected

Click to view rqt_graph

-----> due to character limitation please Click Here to view full description.

Aarif gravatar imageAarif ( 2014-09-24 15:28:59 -0600 )edit

It looks like your simulator isn't subscribing to a command topic. I don't know anything about USARSim, so I can't say more.

P.S. - you can edit your question to add additional information instead of posting it on a 3rd-party site.

ahendrix gravatar imageahendrix ( 2014-09-24 23:02:24 -0600 )edit

The /executive_usarsim/cmd_vel topic isn't published or subscribed to; why are you trying to echo it? You should be able to see if there are any subscribers to the /cmd_vel topic with rostopic info /cmd_vel

ahendrix gravatar imageahendrix ( 2014-09-25 22:57:04 -0600 )edit

hello @ahendrix, thanks for the reply, but how can i make this package to subscribe to the cmd_vel topic. Thanks

Aarif gravatar imageAarif ( 2014-10-10 15:04:22 -0600 )edit

I don't know anything about USARSim, so I can't say more.

ahendrix gravatar imageahendrix ( 2014-10-10 15:39:36 -0600 )edit

A short review of the executive_usarsim codebase suggests that it may not be able to do this. You may want to open an issue on their bugtracker or use a different usarsim package.

ahendrix gravatar imageahendrix ( 2014-10-10 15:53:30 -0600 )edit

thanks @ahendrix, i will try... :)

Aarif gravatar imageAarif ( 2014-10-11 12:11:52 -0600 )edit