Ask Your Question
0

NO cmd_vel on rqt graph

asked 2014-09-26 13:03:17 -0600

updated 2014-10-10 15:06:07 -0600

i want to navigate P3AT robot spawned in usarsim through teleop_twist_keyboard package (in ROS).

I have connected ros to usarsim using executive_usarsim package and spawned the P3AT robot in usarsim, but when i run teleop_twist_keyboard and presses keys to move the robot, nothing happens. please help me out.

I have tried to run $rosrun rqt_graph rqt_graph, the following rqt graph appears: Click to view rqt_graph

then i have run $ rostopic echo /executive_usarsim/status, following graph appeared: Click to view graph

then i observed the cmd_vel is not present. what to do next. please help.

NOTE: i am using ROS-fuerte on UBUNTU 12.04 LTS. [with USARSim simulator] see full description: click here

edit retag flag offensive close merge delete

Comments

cmd_vel is not published so its not on rqt_graph. try rostopic info cmd_vel to see topic publishers and subcribers

bvbdort gravatar imagebvbdort ( 2014-09-27 05:13:24 -0600 )edit

hello, @bvbdort . from rostopic info cmd_vel.

publisher: teleop_twist_keyboard

subscriber: None

since no one is subscriber. i want executive_usarsim to be a subscriber.

here is the rqt graph obtained. https://tucrlab.files.wordpress.com/2...

sumant gravatar imagesumant ( 2014-10-10 14:54:39 -0600 )edit

Are you sure that executive_usarsim is subscribing to cmd_vel topic? You may wanna view "All Nodes and Topics" in rqt_graph (Upper left drop down menu) or check it using rostopic list. Also, check your launch file if you are using remap to change topic names.

ajain gravatar imageajain ( 2014-10-17 01:06:27 -0600 )edit

i am using usarsim_inf & it works fine.

sumant gravatar imagesumant ( 2014-10-23 07:16:20 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2015-05-02 16:21:38 -0600

Aarif gravatar image

hi @sumant,

you executive_usarsim node is not subscribing to the /cmd_vel topic that's why it is not shown in you rqt_graph. you can do following things to drive robot:-

  1. Check, on which topic your executive_usarsim node is expected to receive twist message and remap the teleop_twist_keyboard from /cmd_vel to the identified topic.

  2. Use usarsim_inf insted of executive_usarsim.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-09-26 13:03:17 -0600

Seen: 751 times

Last updated: May 02 '15