Ask Your Question
1

Removed Eigen CMake config file

asked 2014-09-22 13:10:59 -0500

pachuc gravatar image

So, I'm having an issue with compilation after moving to an indigo platform on ubuntu 14.04. As I understand it, from here, here, here, and here the FindEigen.cmake is now in /opt/indigo/share/cmake_modules/cmake/Modules/. I see this on my system, and I followed the instructions to add cmake_modules as a dependency in both the package.xml and CMakeLists.txt, however, I still get the same error.

The exact error message i get is:

    CMake Error at /opt/ros/indigo/share/catkin/cmake/catkinConfig.cmake:75 (find_package):
  Could not find a package configuration file provided by "eigen" with any of
  the following names:

    eigenConfig.cmake
    eigen-config.cmake

  Add the installation prefix of "eigen" to CMAKE_PREFIX_PATH or set
  "eigen_DIR" to a directory containing one of the above files.  If "eigen"
  provides a separate development package or SDK, be sure it has been
  installed.
Call Stack (most recent call first):
  vigir_atlas_ros_control/vigir_atlas_controller/CMakeLists.txt:20 (find_package)


-- Configuring incomplete, errors occurred!
See also "/home/pachu/flor_repo/catkin_ws/build/CMakeFiles/CMakeOutput.log".
See also "/home/pachu/flor_repo/catkin_ws/build/CMakeFiles/CMakeError.log".
Invoking "cmake" failed

So... I'm not really sure what else to try. I was working with vigir_atlas_ros_control/vigir_atlas_controller/CMakeLists.txt to add the dependencies but nothing seemed to change. Do i have to change something in /opt/ros/indigo/share/catkin/cmake/catkinConfig.cmake? Any help would be greatly appreciated.

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
2

answered 2014-09-22 13:25:48 -0500

paulbovbel gravatar image

cmake variables are case sensitive, are you sure you're using find_package(Eigen REQUIRED)?

Here is a pull that includes the sum total of the changes you'd (ideally) need to make for migration:

https://github.com/ros-perception/per...

edit flag offensive delete link more

Comments

1

In case it's unclear to anyone else, this wasn't a case sensitivity issue. The CMakeLists.txt was missing find_package(cmake_modules REQUIRED).

Cerin gravatar imageCerin ( 2015-05-03 15:19:06 -0500 )edit

Hi ! I have add "cmake_modules" in find_package . But it still have the same error showed above. Is it something i miss?

qiyuan gravatar imageqiyuan ( 2015-06-02 23:19:03 -0500 )edit
0

answered 2015-12-28 13:47:22 -0500

I'm completely new to ROS (and mac OS X yosemite) and I'm having some trouble when trying to use the command catkin_make (package navigation-indigo-devel):https://github.com/ros-planning/navigation

The error message is the following:

Make Error at /opt/ros/indigo/share/catkin/cmake/catkin_package.cmake:291 (message): catkin_package() absolute include dir '/usr/local/Cellar/eigen/3.2.5/include/eigen3' does not exist Call Stack (most recent call first): /opt/ros/indigo/share/catkin/cmake/catkin_package.cmake:98 (_catkin_package) navigation/costmap_2d/CMakeLists.txt:60 (catkin_package)

-- Configuring incomplete, errors occurred! See also "/Users/Amine/catkin_ws/build/CMakeFiles/CMakeOutput.log". See also "/Users/Amine/catkin_ws/build/CMakeFiles/CMakeError.log". make: * [cmake_check_build_system] Error 1 Invoking "make cmake_check_build_system" failed

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-09-22 13:10:59 -0500

Seen: 2,133 times

Last updated: Sep 22 '14