Ask Your Question
2

Vslam ubuntu packages not installing

asked 2011-03-14 21:07:04 -0600

KoenBuys gravatar image

updated 2014-01-28 17:09:21 -0600

ngrennan gravatar image

I want to move from my Cturtle vslam installation to the diamondback version. After doing a sudo aptitude update and a sudo aptitude full-upgrade I try to install the ros-diamondback-vslam package however this fails because of different version dependencies:

koen@pma-09-031 ~ $ sudo aptitude install ros-diamondback-vslam 
The following NEW packages will be installed:
ros-diamondback-vslam{b} 
0 packages upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 155MB of archives. After unpacking 357MB will be used.
The following packages have unmet dependencies:
ros-diamondback-vslam: Depends: ros-diamondback-common-msgs (= 1.4.0-    s1298335197~maverick) but 1.4.0-s1299027564~maverick is installed.
                     Depends: ros-diamondback-driver-common (= 1.2.3-s1298335910~maverick) but 1.2.3-s1299028362~maverick is installed.
                     Depends: ros-diamondback-geometry (= 1.4.1-s1298335454~maverick) but 1.4.1-s1299027844~maverick is installed.
                     Depends: ros-diamondback-image-common (= 1.4.0-s1298338010~maverick) but 1.4.1-s1299029857~maverick is installed.
                     Depends: ros-diamondback-perception-pcl (= 0.9.0-s1298335998~maverick) but 0.10.0-s1299028482~maverick is installed.
                     Depends: ros-diamondback-ros (= 1.4.5-s1298334205~maverick) but 1.4.6-s1298587732~maverick is installed.
                     Depends: ros-diamondback-ros-comm (= 1.4.3-s1298334655~maverick) but 1.4.5-s1299027222~maverick is installed.
                     Depends: ros-diamondback-vision-opencv (= 1.4.1-s1298342629~maverick) but 1.4.1-s1299035380~maverick is installed.
The following actions will resolve these dependencies:

 Keep the following packages at their current version:
 1)     ros-diamondback-vslam [Not Installed]              

 Accept this solution? [Y/n/q/?] n

 *** No more solutions available ***

 The following actions will resolve these dependencies:

 Keep the following packages at their current version:
 1)     ros-diamondback-vslam [Not Installed]              

 Accept this solution? [Y/n/q/?] q
 Abandoning all efforts to resolve these dependencies.
 Abort.

Is this caused by a problem in the package generation?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2011-03-15 04:05:12 -0600

kwc gravatar image

vslam is currently broken, so the debian packages are not available for diamondback. You will have to install from source if you wish to use it. In general, experimental/research stacks may often go into a broken state, at which point their debian packages will be pulled.

edit flag offensive delete link more

Comments

Is there a protocol to notify such broken debian packages? Or do I file a ticket each time?
KoenBuys gravatar imageKoenBuys ( 2011-03-15 20:43:13 -0600 )edit
The debian build status pages http://www.ros.org/wiki/release will give you information about what is in the repository. Pre-1.0 stacks should be considered volatile and will be pulled if broke. Stack owners are generally aware when their stacks are pulled, so there is no need to file a ticket.
kwc gravatar imagekwc ( 2011-03-16 03:52:22 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-03-14 21:07:04 -0600

Seen: 301 times

Last updated: Mar 15 '11