Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Removed Eigen CMake config file

So, I'm having an issue with compilation after moving to an indigo platform on ubuntu 14.04. As I understand it, from here, here, here, and here the FindEigen.cmake is now in /opt/indigo/share/cmake_modules/cmake/Modules/. I see this on my system, and I followed the instructions to add cmake_modules as a dependency in both the package.xml and CMakeLists.txt, however, I still get the same error.

The exact error message i get is:

    CMake Error at /opt/ros/indigo/share/catkin/cmake/catkinConfig.cmake:75 (find_package):
  Could not find a package configuration file provided by "eigen" with any of
  the following names:

    eigenConfig.cmake
    eigen-config.cmake

  Add the installation prefix of "eigen" to CMAKE_PREFIX_PATH or set
  "eigen_DIR" to a directory containing one of the above files.  If "eigen"
  provides a separate development package or SDK, be sure it has been
  installed.
Call Stack (most recent call first):
  vigir_atlas_ros_control/vigir_atlas_controller/CMakeLists.txt:20 (find_package)


-- Configuring incomplete, errors occurred!
See also "/home/pachu/flor_repo/catkin_ws/build/CMakeFiles/CMakeOutput.log".
See also "/home/pachu/flor_repo/catkin_ws/build/CMakeFiles/CMakeError.log".
Invoking "cmake" failed

So... I'm not really sure what else to try. I was working with vigir_atlas_ros_control/vigir_atlas_controller/CMakeLists.txt to add the dependencies but nothing seemed to change. Do i have to change something in /opt/ros/indigo/share/catkin/cmake/catkinConfig.cmake? Any help would be greatly appreciated.