Ask Your Question
0

why some empty areas are with high cost in costmap? [closed]

asked 2014-09-12 04:23:55 -0500

scopus gravatar image

updated 2014-09-12 07:55:45 -0500

Hi, all ,I am using turtlebot2( i.e. kobuki) to test my local planner. The global_planner being used is the default navfn of move_base node (i.e. navfn). But some strange path planning happen due to the incorrect costmap (global costmap ?). Please see following two images. The black and grey areas are with high cost from global costmap. The red ellipses are the areas that should be with white. Because there are nothing on these area. Beforehand some moving objects such as persons were moving through these areas. But when a turtlebot robot is ordered to go from start points ( blue squares) to goal points (orange squares), there are nothing in these areas. That is why the planned path(green lines) get round these areas like there exists obstacles.

image description image description

Here I give the yaml files that the move_base node is using.

local_costmap_params.yaml:

local_costmap:
   global_frame: odom #was /odom
   robot_base_frame: base_link #was /base_footprint
   update_frequency: 5.0
   publish_frequency: 5.0
   static_map: false
   rolling_window: true
   width: 4.0
   height: 4.0
   resolution: 0.1
   transform_tolerance: 0.5

global_costmap_params.yaml:

global_costmap:
   global_frame: /map
   robot_base_frame: base_link # was /base_footprint
   update_frequency: 5.0
   publish_frequency: 1.0
   static_map: true
   transform_tolerance: 0.5
   cost_scaling_factor: 10.0
   lethal_cost_threshold: 100

costmap_common_params:

max_obstacle_height: 0.60  # assume something like an arm is mounted on top of the robot
obstacle_range: 2.5
raytrace_range: 3.0
robot_radius: 0.18
inflation_radius: 0.50
observation_sources: scan bump
scan: {data_type: LaserScan, topic: /scan, marking: true, clearing: false}
bump: {data_type: PointCloud2, topic: mobile_base/sensors/bumper_pointcloud, marking: true, clearing: false}

How to change these grey areas into white area in time?

One more thing, I think the grey areas attached to static object (black bold lines from wall and desk) in my map are thicker than I request like the grey area around the desk, how to make them thin? Thank you

Edit: one picture is replaced.

Dear (@Fernando\ Herrero), Thank you for your attention. So I should change the inflation radius smaller to be 0.20, i.e. 0.20m.

However, please note the second picture. The white lines are the laser scan, so the area in red ellipse is scanned but still in grey. Why? Thank you!

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by scopus
close date 2014-09-19 07:45:29.506683

Comments

The global costmap is updated with the scan if it has an obstacle layer. If these areas are result of mobile obstacles, they should be cleared by the scan when you go there again and it's free. The thick areas are result of the obstacle inflation, to prevent the robot to get too close to obstacles

fherrero gravatar image fherrero  ( 2014-09-12 05:08:45 -0500 )edit

However, please note the second picture. The white lines are the laser scan, so the area in red ellipse is scanned but still in grey. Why? Thank you!

scopus gravatar image scopus  ( 2014-09-12 07:56:03 -0500 )edit

1 Answer

Sort by » oldest newest most voted
1

answered 2014-09-12 22:01:38 -0500

scopus gravatar image

I got the solution: the parameter in common_costmap.yaml for laserscan , that is "Clearing" should be "true". Right? Thank you!

edit flag offensive delete link more

Question Tools

2 followers

Stats

Asked: 2014-09-12 04:23:55 -0500

Seen: 332 times

Last updated: Sep 12 '14