Problems with move_base [closed]

asked 2014-09-10 08:39:27 -0600

updated 2014-09-12 04:11:44 -0600

I have a movable robot which I control properly with the ps3 joystick. I have implemented recently an AMCL filter and a path planning with move_base package.

When I try to move the robot defining a goal it can not turn or go backward. The only movement it accomplish is moving forward.

I am using Hydro and this is my config file: If it is necessary I can send you any bagfile you need. Thank you.

[EDIT] I have been looking cmd_vel topic and the angular velocity never comes up to 0.5 and I know that lower values than 1.2 makes no movement in the robot. I don't understand why it is happening because I have set the max_vel_theta to 10.0

TrajectoryPlannerROS:

  # Robot Configuration Parameters

  acc_lim_x: 2.5
  acc_lim_y: 2.5
  acc_lim_th: 10.0                   ##3.5
  max_vel_x: 10.0 #1.0
  min_vel_x: 0.5 #0.1
  max_vel_theta: 10.0
  min_vel_theta: -10.0
  min_in_place_vel_theta: 0.3
  escape_vel: -0.1
  holonomic_robot: false

  # Goal Tolerance Parameters

  xy_goal_tolerance: 0.6
  yaw_goal_tolerance: 0.1

  # Forward Simulation Parameters

  sim_time: 1.3          ##1.3
  sim_granularity: 0.20  ##0.2
  vx_samples: 10         ##10
  vtheta_samples: 30

  # Trajectory Scoring Parameters

  meter_scoring: false
  gdist_scale: 0.7   ##0.6
  pdist_scale: 1.5   ##1.0
  occdist_scale: 0.01       ##0.05
  heading_lookahead: 3.0    ##1.5  dwa: true

  heading_scoring: true            ##false
  heading_scoring_timestep: 1.0    ##0.8


  # Oscillation Prevention Parameters

  oscillation_reset_dist: 0.2
edit retag flag offensive reopen merge delete

Closed for the following reason question is off-topic or not relevant. Please see http://wiki.ros.org/Support for more details. by arenillas
close date 2014-09-30 04:16:55.942784

Comments

So it just keeps going straight and misses the goal?

SaiHV gravatar imageSaiHV ( 2014-09-10 12:02:49 -0600 )edit
1

It may be worth looking at the /cmd_vel topic output from move_base to see which commands it's sending.

ahendrix gravatar imageahendrix ( 2014-09-10 13:54:02 -0600 )edit

If the trajectory needs any angular movement it stops and tries to do it. It is like it has not enough strength to accomplish the turn. When the trajectory is linear, the robot makes it well

arenillas gravatar imagearenillas ( 2014-09-11 10:31:45 -0600 )edit

Here's a thought: You have 10 m/s as your max. vel in x, but 1 m/s for theta. May be it's just slow because of the difference? Are you using the turtlebot files and parameters in the nav stack? Did you tweak any of the files?

SaiHV gravatar imageSaiHV ( 2014-09-11 11:40:44 -0600 )edit

I tried with higher values of the theta velocity but I had always the same result. My robot is a SummitXL and I am using the navigation stack trying to configure each parameter

arenillas gravatar imagearenillas ( 2014-09-11 12:03:48 -0600 )edit