Ask Your Question
0

What is the best driver/stack to use with a SICK LMS-1xx?

asked 2014-09-08 17:52:58 -0600

wpd gravatar image

I found the LMS1xx package, but, according to the wiki page, it is only tested/good for groovy, despite the fact that there is a ros-hydro-lms1xx package available for installation. I tried installing ros-hydro-lms1xx and running the LMS1xx.launch script, but it fails to find the LMS1xx_node in the LMS1xx package, because LMS1xx is spelled lms1xx in the .deb file.

It's relatively trivial to fix that, or even to download and recompile the source code from github, but I wonder if I'm heading down an unmaintained path.

So I figured it wouldn't hurt to ask what folks are using nowadays in the Hydro era (which is where I live), or perhaps in the Indigo era, which is arguably, where I should live.

--wpd

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2014-09-09 23:47:31 -0600

ahendrix gravatar image

The package you refer to is released into Groovy, Hydro and Indigo as lms1xx. They did a release into Indigo fairly recently, so it looks like it's actively maintained.

If the launch file doesn't work, you should probably file that as a bug on github, or submit a pull request.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-09-08 17:52:58 -0600

Seen: 416 times

Last updated: Sep 09 '14