ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

Problem with installing LMS1xx [closed]

asked 2013-03-08 04:54:31 -0600

updated 2014-01-28 17:15:35 -0600

ngrennan gravatar image

Hi All,

I am new to both ROS and Ubuntu, so if I am missing anything or doing anything horribly wrong please let me know. I am trying to install the RCPRG_laser_drivers package. I have cloned the git into /opt/ros/groovy/stacks/ and then I ran rosmake -a. When I do this I get the following in the log file: "git clone ht tp:// build/libLMS1xx fatal: could not create leading directories of 'build/libLMS1xx': Permission de$ make: * [build/libLMS1xx] Error 128" If I run rosmake /opt/ros/groovy/RCPRG_laser_drivers I get the message: "[ rosmake ] rosmake starting...
[ rosmake ] Packages requested are: ['/opt/ros/groovy/stacks/RCPRG_laser_drivers'] [ rosmake ] Logging to directory /home/lemur2/.ros/rosmake/rosmake_output-20130308-112429 [ rosmake ] Expanded args ['/opt/ros/groovy/stacks/RCPRG_laser_drivers'] to: [] [ rosmake ] WARNING: The following args could not be parsed as stacks or packages: ['/opt/ros/groovy/stacks/RCPRG_laser_drivers'] [ rosmake ] ERROR: No arguments could be parsed into valid package or stack names."

I would appreciate any help with this. As I have mentioned, I am brand new at this so I could be missing something completely obvious and not know it.


edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Icehawk101
close date 2013-03-25 07:35:09



I suggest running through the ROS tutorials. They'll help you understand how to create/build packages. In this case, you are attempting to build in a system directory, which is not recommended (moreover, by default, not permitted)

Ryan gravatar image Ryan  ( 2013-03-08 16:17:56 -0600 )edit

I've read over the tutorials, at least the early ones. I've moved the folder out of the system directory and into my home folder. Still getting the second part with the warnings.

Icehawk101 gravatar image Icehawk101  ( 2013-03-09 06:22:29 -0600 )edit

2 Answers

Sort by ยป oldest newest most voted

answered 2013-03-12 18:05:08 -0600

I got it installed. It was because I was messing up. I didn't edit the .bashrc right so my workspace wasn't on the ros package path. Once I fixed that the package installed correctly.

edit flag offensive delete link more

answered 2013-03-12 13:02:28 -0600

tfoote gravatar image

When you call rosmake you don't use the full path, you need to use the package name.

edit flag offensive delete link more


I tried calling the whole path since if I just called the package name it failed. Then again, it failed anyway.

Icehawk101 gravatar image Icehawk101  ( 2013-03-12 18:03:11 -0600 )edit

Question Tools


Asked: 2013-03-08 04:54:31 -0600

Seen: 597 times

Last updated: Mar 12 '13