Ask Your Question
0

SICK LMS1XX connectivity issue lms111 ROS kinetic

asked 2017-08-02 08:05:48 -0500

victorschiaveto gravatar image

updated 2019-04-06 18:30:43 -0500

jayess gravatar image

Hello,

I am ussing the LMS1XX package on Kinetic , and I couldn't get it connected.

rosrun lms1xx LMS1xx_node _host:=[ip from Sopas Engineering Toolbox from Sick]

e.g.

rosrun lms1xx LMS1xx_node _host:=169.254.145.188

Connecting to laser at 169.254.145.188
Unable to connect, retrying.

I set the Mac Adress, IPv4, Netmask like here

Did

sudo ifconfig

No laser found from find_sick node and I couldn't get the set_sick_ip to work because I don't know the arguments format.

IP shows on sick software

169.254.145.188 ... LMS111-10100 Fw V1.80.1

Nothing works.. Any help?

edit retag flag offensive close merge delete

Comments

Did you solved this problem?

AlexR gravatar image AlexR  ( 2017-10-01 22:25:42 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2019-03-30 17:17:25 -0500

bsheffield gravatar image

The IP address that you saw in the SICK software is not a valid ip address, 169.254.145.188.

Change the IP address to something that is valid like 192.168.1.123 with the SOPAS Engineering Toolbox.

edit flag offensive delete link more

Comments

1

The IP address that you saw in the SICK software is not a valid ip address

I'm not sure this is entirely correct. IPs in the range 169.254.x.x are in the APIPA or link local range. They're certainly valid IP addresses. They may change next tim the device is started though, so configuring a static IP address may be a good idea.

gvdhoorn gravatar image gvdhoorn  ( 2019-03-31 02:35:22 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-08-02 08:05:48 -0500

Seen: 615 times

Last updated: Apr 06 '19