Ask Your Question
0

Connecting a Sick laserscanner via ethernet

asked 2015-04-16 02:54:37 -0600

Sander gravatar image

Hi,

We're working on our robot running Ubuntu 14.04 and ROS indigo. Right now we are trying to connect a Sick LMS 111 laserscanner via ethernet. We installed the drivers http://wiki.ros.org/LMS1xx and can start the node to do this. Afterwards we tried to connect to the laserscanner using many ip's (found by ifconfig for example) but any of them gave back this error:

[ INFO] [1429170035.841400945]: Connecting to laser at : 192.168.0.1:2111
[ERROR] [1429170163.097305396]: Connection to LMS1xx device failed, retrying in 1 second.

To find the port we downloaded the Sopas Engineering Toolbox from Sick. This gave us ip 192.168.0.1 and tcp 2111. To set the port we adjusted the launch file:

<launch>
  <arg name="host" default="192.168.0.1:2112" />
  <node pkg="lms1xx" name="lms1xx" type="LMS1xx_node" output="screen">
    <param name="host" value="$(arg host)" />
  </node>
</launch>

Does anyone have an idea on how to get data from the laserscanner?

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2015-05-16 10:25:11 -0600

danimtb gravatar image

Hi! It is not necessary to indicate port in laser's ip address, just write <arg name="host" default="192.168.0.1" />. Default port connection is set to 2111, which is the usual port SOPAS gives to sick lms 1xx laser scanners.

If this does not solve the problem, try adjusting your manual ethernet connection to suit a similar address to the laser's one.

edit flag offensive delete link more

Comments

2

You're correct. The problem was that we manually added a connection in Ubuntu with 192.168.0.1 as ip address. The trick was that the ip address has to be different from the ip address from the laserscanner. Thus when we added 192.168.0.2 as ip address on that ethernet port it worked.

Sander gravatar imageSander ( 2015-05-17 04:27:06 -0600 )edit

Great to see it worked! I am using Sick LMS100 with LMS1xx node too and I'm able to connect to the laserscanner but after a few minutes the node stops sending data.

Could you tell the ethernet configuration you are using (IP, MASK, GATEWAY)? I suppose your ethernet connection is set to manual. Thx

danimtb gravatar imagedanimtb ( 2015-05-17 12:30:26 -0600 )edit

On edit connections, click add, go to ethernet tab, set device MAC address to the right ethernet port, got to IPv4 Settings tab, set method to Manual and enter these settings: Address: 192.168.0.1 Netmask: 255.255.255.0 Leave Gateway open and click save.

Sander gravatar imageSander ( 2015-05-18 01:32:12 -0600 )edit

Thanks for your comment, now it is working except when I connect my computer to a router via wifi at the same time.

If I disconnect wifi it works great but with wifi connection I have same problem: node connects to lms100 well but after a while it stops sending data...

Did you have this problem?

danimtb gravatar imagedanimtb ( 2015-05-19 07:36:08 -0600 )edit
0

answered 2017-04-04 09:11:01 -0600

vik748 gravatar image

After trying a number of driver and packages for our SICK LMS511 the best one I found to work with my ROS Indigo was from https://github.com/pangfumin/lms511_l...

All I had to do was initialize a workspace, copy the folder laser_node into the src folder and then catkin_make. Hope this helps someone else.

Cheers, Vik

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2015-04-16 02:54:37 -0600

Seen: 8,640 times

Last updated: May 16 '15