Ask Your Question
1

navigation , no message receive from trajectory planner!

asked 2011-12-20 02:00:11 -0600

Hi all, i am running navigation with static map , but when i set a 2Dgoal in rviz robot doesn't move. In rviz , state of local planner & global planner & planner plan, objects is warning with given info:"no message receive !" I am running roswtf and from the output i have realized that the only topics that are not connected are: "/move_base_simple/goal" & "/move_base/cancel" Any ideas?

thanks in advance.

edit retag flag offensive close merge delete

Comments

What robot are you trying to run and what launch file are you using?
DimitriProsser gravatar image DimitriProsser  ( 2011-12-20 02:01:40 -0600 )edit
What do you have specified as the 2D nav goal topic in rviz?
Eric Perko gravatar image Eric Perko  ( 2011-12-20 06:23:53 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2011-12-20 23:41:25 -0600

Problem solved! Rviz goal was not connected to /move_base_simple/goal , i have changed topics name to goal , then the problem solved!

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-12-20 02:00:11 -0600

Seen: 138 times

Last updated: Dec 20 '11