Ask Your Question
0

rviz segfault in ros-electric

asked 2011-09-27 02:53:22 -0500

kexiang gravatar image

I have just installed ros-electric. However, when I tried "rosrun rviz rviz", the error occurred as: [ INFO] [1317134200.383469425]: rviz revision number 1.6.4 [ INFO] [1317134200.383560843]: ogre_tools revision number 1.6.2 [ INFO] [1317134200.383580665]: compiled against OGRE version 1.7.3 (Cthugha) Segmentation fault

My os's version is ubuntu11.04, and gpu is ATI HD6630. Thank you for your help.

edit retag flag offensive close merge delete

Comments

The developers will probably need a gdb stack backtrace to help with this.
joq gravatar image joq  ( 2011-09-27 04:40:06 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
2

answered 2011-09-27 10:31:06 -0500

Hi kexiang, I suppose you have the same problem discussed here http://answers.ros.org/question/2109/rviz-in-ros-electric#3609

I think you should look at hersh 2nd answer. If you have still problems post the same things I posted in my last answer.

Hope it helps!

edit flag offensive delete link more

Comments

Thank you for answering. Before your answer,I tried uninstall the closed driver of ATI, then rviz worked normally. However, it still gives out information: [ INFO] [1317209727.036570342]: compiled against OGRE version 1.7
kexiang gravatar image kexiang  ( 2011-09-27 23:36:40 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-09-27 02:53:22 -0500

Seen: 306 times

Last updated: Sep 27 '11