ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | Q&A
Ask Your Question

Building Angstrom following wiki: where is the image...

asked 2013-10-03 03:55:25 -0600

hvn gravatar image

updated 2013-10-03 21:09:39 -0600


Following this tutorial, I first tried option 1. I have Angstrom with kernel 2.6.32, but I followed the instructions which left me with a ruined BeagleBoard-xM system. Several other "users" had been created, I could no longer log in as user, only as root and ROS was not installed. After flashing the kernel again and running git, I checked using "opkg list" for ROS packages and none were available. So I guess the recommendation should be "only with latest kernel". Then I build an image, but after building it I can't find the image. What is it called, where is it? Then I used bitbake for cross-compiling ROS. When that finished, I checked for ROS packages and found none. Where should I find them ?

Edit: I tried to create the image again and this time it even goes wrong before the image is finalized giving this error:

NOTE: Error during finalise of /home/<user>/devel/setup-scripts/sources/openembedded-core/meta/recipes-extended/images/ ERROR: ExpansionError during parsing /home/<user>/devel/setup-scripts/sources/openembedded-core/meta/recipes-extended/images/ Failure expanding variable toolchain_create_sdk_version: ExpansionError: Failure expanding variable METADATA_REVISION, expression was ${@base_detect_revision(d)} which triggered exception OSError: [Errno 12] Cannot allocate memory NOTE: Error during finalise of /home/<user>/devel/setup-scripts/sources/openembedded-core/meta/recipes-extended/images/ ERROR: Command execution failed: Exited with 1

Summary: There were 2 ERROR messages shown, returning a non-zero exit code.

I guess I'm doing something wrong, but no clue what....

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted

answered 2013-10-04 00:49:04 -0600

hvn gravatar image


The problem is the combination of Angstrom and ROS. When I install Ubuntu I can install ROS groovy (and hydro) without a problem. The problem is that I want DSP as well, which is actively supported by Angstrom only.

Maybe I wasn't clear enough about this, but my latest attempts were building the image following, options 1 and 2, so I did follow The first time it seemed to go fine, just couldn't find where the image was. The second time, the building ends in the reported errors.

Will be followed up...

edit flag offensive delete link more

answered 2013-10-03 23:35:33 -0600

v.mayoral gravatar image

Hi hvn,

As we already discussed through there's no support for the BeagleBoard-xM but you're welcome to do it and provide feedback of your results. I don't think the Ångström feed has the beagle-ros recipes cross-compiled for you either so you should do it yourself (check it for your architecture If you cross-compile them yourself there's no need to search in the feed, just install them.

Regarding your issue, it seem you're having trouble with Ångström and not with the Beagle-ROS recipes. Did you try building simple recipes? Maybe you could start building an image for your board following You should make sure that your Ångström build environment is properly set up before trying to cross-compile the Beagle-ROS recipes. If you're still having issues ask for help

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower


Asked: 2013-10-03 03:55:25 -0600

Seen: 1,273 times

Last updated: Oct 04 '13