Ask Your Question
0

Received 'rospack failed to build' message when executed rosmake

asked 2012-03-19 08:34:12 -0500

manu gravatar image

updated 2014-04-20 14:09:35 -0500

ngrennan gravatar image

Hello,

I'm totally new with ROS and all the robot related stuff, so I'm following all the instructions here to get involved and learn how ROS works.

I'm using Fedora 15 and followed these instructions http://www.ros.org/wiki/electric/Installation/Fedora to install ROS. Everything worked fine, so I continued with the tutorials indicated in this same page to start learning ROS.

Everything was fine until I arrived to the building packages tutorial, I was able to create my first package but when I tried to build it I get the following message:

[manu@manu beginner_tutorials]$ rosmake beginner_tutorials
Rospack failed to build

I have no idea what can be causing this, I did a search at Google and at the ROS answers page but haven't find yet how to solve this. The most similar error I found related to this pointed to the CDPATH environment variable, but I have already verified that this variable is not set in my machine and also if I set it to '.' get the same result.

I'll really appreciate any suggestion or tip about how to debug this, I know this may be a configuration error or a very elemental question, but I hope that soon I could get more involved with how all this works :D.

edit retag flag offensive close merge delete

Comments

Any suggestions about how to debug this??? I haven't found an answer yet, I'm trying to debug the makefiles to know what can be causing this

manu gravatar image manu  ( 2012-03-27 02:34:45 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
1

answered 2012-04-10 07:10:02 -0500

manu gravatar image

Solved this... it was a permission issue causing the build to fail.

edit flag offensive delete link more

Comments

how do you solve it? i have the same issue

Kzr gravatar image Kzr  ( 2015-12-06 12:41:31 -0500 )edit
0

answered 2012-04-09 16:41:34 -0500

tfoote gravatar image

This suggests that you are missing one or more of the prerequisites for building.

http://www.ros.org/wiki/electric/Installation/Fedora#Setup

You can got to the rospack package itself and type make in the package to get more errors visible.

edit flag offensive delete link more

Comments

Thank you very much for your response. I followed the instructions on this link when doing installation, it completed fine and most of the ROS commands are working right now. If I go to the package itself and run 'make' the build completes in the packages I created myself.

manu gravatar image manu  ( 2012-04-10 01:23:09 -0500 )edit

But if I try to build a package provided by ROS, like the required on this tutorial: http://www.ros.org/wiki/ROS/Tutorials/BuildingPackages , it fails with the following error:

manu gravatar image manu  ( 2012-04-10 01:27:55 -0500 )edit

[manu@manu rospy_tutorials]$ sudo make [sudo] password for manu: make: rospack: Command not found Makefile:1: /cmake.mk: No such file or directory make: * No rule to make target `/cmake.mk'. Stop.

manu gravatar image manu  ( 2012-04-10 01:28:20 -0500 )edit
1

It seems that the Makefile is not resolving the path for the 'cmake.mk' file correctly, but I have no idea of why. Do you have any suggestion about this. If it helps in someway, the Makefile looks like: include $(shell rospack find mk)/cmake.mk

manu gravatar image manu  ( 2012-04-10 01:31:20 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-03-19 08:34:12 -0500

Seen: 733 times

Last updated: Apr 10 '12