Ask Your Question
0

When I try to "catkin build" I get error messages

asked 2019-02-16 12:57:47 -0600

acikbasm gravatar image

updated 2019-02-18 01:28:01 -0600

gvdhoorn gravatar image

I am using Ubuntu 16.04 64-bit.V-REP 3.5.0 64 bit.ROS Kinetic desktop full, joystick and brics actuator packages. When I try to "catkin build" under my ROS ws I receive following error messages. How can I sort them out?

CMake Error at /opt/ros/kinetic/share/catkin/cmake/catkinConfig.cmake:83 (find_package):
  Could not find a package configuration file provided by "joy" with any of
  the following names:

    joyConfig.cmake
    joy-config.cmake

 Add the installation prefix of "joy" to CMAKE_PREFIX_PATH or set... 

...

Failed     << vrep_joy:cmake                       
                  [ Exited with code 1 ]
Failed    <<< vrep_joy                             
                   [ 3.8 seconds ]
Abandoned <<< vrep_teleop                          
                       [ Unrelated job failed ]
Abandoned <<< vrepscan_to_laserscan                
                       [ Unrelated job failed ]
Finished  <<< vrep_common                          
                   [ 6.5 seconds ]
[build] Summary: 3 of 6 packages succeeded.
[build]   Ignored:   None.           
[build]   Warnings:  None.           
[build]   Abandoned: 2 packages were abandoned.
[build]   Failed:    1 packages failed.
[build] Runtime: 7.0 seconds total.
edit retag flag offensive close merge delete

Comments

You're not showing actual errors, just the summary output of catkin_tools that tells us something failed to compile.

gvdhoorn gravatar imagegvdhoorn ( 2019-02-17 04:39:45 -0600 )edit

Maybe expression was not good enough but anyway at some further step at my processes I needed them have installed all correctly. To re-ask the question in another way; how to complete that compilation then?

acikbasm gravatar imageacikbasm ( 2019-02-17 12:42:38 -0600 )edit

CMake Error at /opt/ros/kinetic/share/catkin/cmake/catkinConfig.cmake:83 (find_package): Could not find a package configuration file provided by "joy" with any of the following names:

joyConfig.cmake
joy-config.cmake

Add the installation prefix of "joy" to CMAKE_PREFIX_PATH or set...

acikbasm gravatar imageacikbasm ( 2019-02-17 13:11:03 -0600 )edit

I think above message is the error message.

acikbasm gravatar imageacikbasm ( 2019-02-17 13:11:39 -0600 )edit

It would appear you have not installed all dependencies prior to starting the build.

Please refer to #q252478 for the general workflow when attempting to build pkgs from sources.

gvdhoorn gravatar imagegvdhoorn ( 2019-02-18 01:29:10 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2019-02-18 11:02:03 -0600

kosmastsk gravatar image

sudo apt-get install ros-kinetic-joy should solve your problem and then source your workspace again.

edit flag offensive delete link more

Comments

when I do it I get another set of error messages as below... E: Encountered a section with no Package: header E: Problem with MergeList /var/lib/apt/lists/packages.ros.org_ros_ubuntu_dists_xenial_main_binary-amd64_Packages

acikbasm gravatar imageacikbasm ( 2019-02-18 13:49:28 -0600 )edit

Try to remove the existing Merge List with sudo rm -vf /var/lib/apt/lists/* and then create a new one with sudo apt-get updatesource

kosmastsk gravatar imagekosmastsk ( 2019-02-18 13:55:41 -0600 )edit

Thanks that worked well. Now only 1 minor issue the rest of the installation was completed...

acikbasm gravatar imageacikbasm ( 2019-02-18 14:24:24 -0600 )edit
1

You can mark this question as solved and open a new question, if needed, for your installation ;)

kosmastsk gravatar imagekosmastsk ( 2019-02-18 14:26:49 -0600 )edit

Now I have one remaining issue apart from that in case you know; I try to run a robot simulation in V-rep at ubuntu 16.04. First I type roscore, then I initialize V-rep, and then I open a simple simulation code which is in *.ttt file. Afterall, I type command "roslaunch vrep_apps base.launch" but...

acikbasm gravatar imageacikbasm ( 2019-02-18 14:27:48 -0600 )edit

I get another error message: [base.launch] is neither a launch file in package [vrep_apps] nor is [vrep_apps] a launch file name The traceback for the exception was written to the log file.

acikbasm gravatar imageacikbasm ( 2019-02-18 14:28:22 -0600 )edit

Any idea about this issue?

acikbasm gravatar imageacikbasm ( 2019-02-18 14:28:40 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2019-02-16 12:57:47 -0600

Seen: 348 times

Last updated: Feb 18