Ask Your Question
0

No realsense device were found!

asked 2019-03-12 09:41:03 -0500

alessiadele gravatar image

Hi all! I have Ubuntu 16.04 LTS and a kinetic ROS on my pc. I am trying to stream a realsense node, but my computer doesn't read anymore the realsense sr300 camera that I am using, and I don't know why! I mean.. I have used it at the end of january and it worked perfectly! After I didn't execute any upgrade or similar, and now when I try to start the node 'roslaunch realsense2_camera rs_camera.launch', the terminal show me this output:

started roslaunch server http://alessiadele:39303/

SUMMARY

PARAMETERS * /camera/realsense2_camera/accel_fps: 1000 * /camera/realsense2_camera/accel_optical_frame_id: camera_accel_opti... * /camera/realsense2_camera/align_depth: False * /camera/realsense2_camera/aligned_depth_to_color_frame_id: camera_aligned_de... * /camera/realsense2_camera/aligned_depth_to_fisheye_frame_id: camera_aligned_de... * /camera/realsense2_camera/aligned_depth_to_infra1_frame_id: camera_aligned_de... * /camera/realsense2_camera/aligned_depth_to_infra2_frame_id: camera_aligned_de... * /camera/realsense2_camera/base_frame_id: camera_link * /camera/realsense2_camera/color_fps: 30 * /camera/realsense2_camera/color_frame_id: camera_color_frame * /camera/realsense2_camera/color_height: 480 * /camera/realsense2_camera/color_optical_frame_id: camera_color_opti... * /camera/realsense2_camera/color_width: 640 * /camera/realsense2_camera/depth_fps: 30 * /camera/realsense2_camera/depth_frame_id: camera_depth_frame * /camera/realsense2_camera/depth_height: 480 * /camera/realsense2_camera/depth_optical_frame_id: camera_depth_opti... * /camera/realsense2_camera/depth_width: 640 * /camera/realsense2_camera/enable_color: True * /camera/realsense2_camera/enable_depth: True * /camera/realsense2_camera/enable_fisheye: True * /camera/realsense2_camera/enable_imu: True * /camera/realsense2_camera/enable_infra1: True * /camera/realsense2_camera/enable_infra2: True * /camera/realsense2_camera/enable_pointcloud: False * /camera/realsense2_camera/enable_sync: False * /camera/realsense2_camera/filters: * /camera/realsense2_camera/fisheye_fps: 30 * /camera/realsense2_camera/fisheye_height: 480 * /camera/realsense2_camera/fisheye_optical_frame_id: camera_fisheye_op... * /camera/realsense2_camera/fisheye_width: 640 * /camera/realsense2_camera/gyro_fps: 1000 * /camera/realsense2_camera/gyro_optical_frame_id: camera_gyro_optic... * /camera/realsense2_camera/infra1_fps: 30 * /camera/realsense2_camera/infra1_frame_id: camera_infra1_frame * /camera/realsense2_camera/infra1_height: 480 * /camera/realsense2_camera/infra1_optical_frame_id: camera_infra1_opt... * /camera/realsense2_camera/infra1_width: 640 * /camera/realsense2_camera/infra2_fps: 30 * /camera/realsense2_camera/infra2_frame_id: camera_infra2_frame * /camera/realsense2_camera/infra2_height: 480 * /camera/realsense2_camera/infra2_optical_frame_id: camera_infra2_opt... * /camera/realsense2_camera/infra2_width: 640 * /camera/realsense2_camera/json_file_path: * /camera/realsense2_camera/pointcloud_texture_index: 0 * /camera/realsense2_camera/pointcloud_texture_stream: RS2_STREAM_COLOR * /camera/realsense2_camera/rosbag_filename: * /camera/realsense2_camera/serial_no: * /rosdistro: kinetic * /rosversion: 1.12.14

NODES /camera/ realsense2_camera (nodelet/nodelet) realsense2_camera_manager (nodelet/nodelet)

ROS_MASTER_URI=http://localhost:11311

process[camera/realsense2_camera_manager-1]: started with pid [20903] process[camera/realsense2_camera-2]: started with pid [20904] [ INFO] [1552401183.635355993]: Initializing nodelet with 4 worker threads. [ INFO] [1552401183.676348266]: RealSense ROS v2.1.2 [ INFO] [1552401183.676416191]: Running with LibRealSense v2.17.0 [ERROR] [1552401183.804225852]: No RealSense devices were found! Terminating RealSense Node... [FATAL] [1552401184.003623523]: Failed to load nodelet '/camera/realsense2_cameraof type realsense2_camera/RealSenseNodeFactory to managerrealsense2_camera_manager' [camera/realsense2_camera_manager-1] process has died [pid 20903, exit code 1, cmd /opt/ros/kinetic/lib/nodelet/nodelet manager __name:=realsense2_camera_manager __log:=/home/alessiadele/.ros/log/95262374-44d2-11e9-ad1c-54353083c519/camera-realsense2_camera_manager-1.log]. log file: /home/alessiadele/.ros/log/95262374-44d2-11e9-ad1c-54353083c519/camera-realsense2_camera_manager-1.log [camera/realsense2_camera-2] process has died [pid 20904, exit code 255, cmd /opt/ros/kinetic/lib/nodelet/nodelet load realsense2_camera/RealSenseNodeFactory realsense2_camera_manager __name:=realsense2_camera __log:=/home/alessiadele/.ros/log/95262374-44d2-11e9-ad1c-54353083c519/camera-realsense2_camera-2.log]. log file: /home/alessiadele/.ros/log/95262374-44d2-11e9-ad1c-54353083c519/camera-realsense2_camera-2.log all processes on machine have died, roslaunch will exit shutting down processing monitor... ... shutting down processing monitor complete

I've tried with 'sudo apt-get update', and after a long processing, the camera still not work.

Do you have any suggestions? thank you!

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2019-03-12 13:49:39 -0500

Check what version of realsense2 camera you're using. They haven't supported the SR300 in awhile.

https://github.com/intel-ros/realsens...

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2019-03-12 09:41:03 -0500

Seen: 249 times

Last updated: Mar 12