Ask Your Question
0

rtabmap_ros tutorial not working : executable not found

asked 2018-01-19 07:24:31 -0600

Markovicho gravatar image

updated 2018-01-22 02:03:27 -0600

Hey :-)

System: Ubuntu 16.04

ROS: Lunar (tried Kinetic before) Desktop Full

rtabmap version : 0.13.2

My approach ist to use the rtabmap feature in cooperation with Tango ROS Streamer which is already running fine.

I followed the instructions on this tutorial :

http://wiki.ros.org/rtabmap_ros/Tutor...

At step 6 it fails at this command

rosrun rtabmap_ros pointcloud_to_depthimage cloud:=/tango/point_cloud camera_info:=/tango/camera/color_1/camera_info _fixed_frame_id:=start_of_service _decimation:=8 _fill_holes_size:=5

with the error:

[rosrun] Couldn't find executable named pointcloud_to_depthimage below /opt/ros/lunar/share/rtabmap_ros

I already installed rtabmap via:

sudo apt install ros-lunar-rtabmap-ros

What could go wrong ? -_-

best regards and many thanks in advance for any help

Mark

edit retag flag offensive close merge delete

Comments

Did you get any errors when you installed rtabmap? Have your sourced the setup.bash file for ros?

PeteBlackerThe3rd gravatar imagePeteBlackerThe3rd ( 2018-01-19 08:29:11 -0600 )edit

No errors on the installation... setup.bash is attached to my ~/.bashrc as well running "rosdep init && rosdep update" -_-

Markovicho gravatar imageMarkovicho ( 2018-01-19 08:47:25 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2018-01-22 03:27:59 -0600

ChriMo gravatar image

I have already seen the same error, but forgot to write an error report. pointcloud_to_depthimage seems not to be included in the deb package or is not installed. I've compiled rtabmap from source.

edit flag offensive delete link more

Comments

Thanks a lot !!!

This worked:

Markovicho gravatar imageMarkovicho ( 2018-01-22 09:50:49 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-01-19 07:24:31 -0600

Seen: 175 times

Last updated: Jan 22 '18