Ask Your Question
0

Am I using the JointVelocityController correctly? [closed]

asked 2013-08-16 15:42:55 -0500

updated 2014-01-28 17:17:41 -0500

ngrennan gravatar image

I am using Ubuntu 12.04 LTS, ROS Hydro beta, and Gazebo 1.9.0 (the one that is installed with Hydro). When I use a JointVelocityController, I get the following error:

[ INFO] [1376543194.963746055, 0.937000000]: Loaded gazebo_ros_control.
gzserver: /opt/ros/hydro/include/hardware_interface/joint_state_interface.h:71: double hardware_interface::JointStateHandle::getVelocity() const: Assertion `vel_' failed.
Aborted (core dumped)

Instances of JointPositionController work correctly. Initially, I thought this problem was caused by a bug in Gazebo 1.9.0, but the assertion is failing in effort_controllers::JointVelocityController::update(), so the problem might be in ros_controllers. I've uploaded a test case to GitHub:

git clone https://github.com/wunderkammer-laboratory/ackermann_vehicle.git 

To reproduce the error:

roslaunch ackermann_vehicle_gazebo ackermann_vehicle.launch

Am I using the JointVelocityController correctly?

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Jim Rothrock
close date 2013-09-30 11:42:19

1 Answer

Sort by ยป oldest newest most voted
0

answered 2013-09-30 11:40:41 -0500

This problem does not exist in Gazebo 1.9.1.

edit flag offensive delete link more

Question Tools

2 followers

Stats

Asked: 2013-08-16 15:42:55 -0500

Seen: 410 times

Last updated: Sep 30 '13