Ask Your Question
0

Workstation rviz "Could not load model" Error

asked 2013-06-28 04:14:45 -0500

JHarriman gravatar image

updated 2013-11-14 10:34:21 -0500

tfoote gravatar image

For the last couple of days I've been trying to run the preinstalled rviz virtualization demo from my workstation rather than the Turtlebot 2 Asus Laptop and have been unable to successfully load rviz on my workstation. When loading rviz on my workstation I receive the following error in the output:

justyn@justyn-M17xR3:~$ roslaunch turtlebot_rviz_launchers view_robot.launch
... logging to /home/justyn/.ros/log/f1d3b6d8-df6e-11e2-a8cb-446d57eca273/roslaunch-justyn-M17xR3-13144.log
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

started roslaunch server /*Removed server info because karma */

SUMMARY
========

PARAMETERS
 * /rosdistro
 * /rosversion

NODES
  /
    rviz (rviz/rviz)

ROS_MASTER_URI=/*Removed URI info because karma */

core service [/rosout] found
process[rviz-1]: started with pid [13153]
[ERROR] [1372368978.648560741]: Could not load resource [package://kobuki_description/meshes/base.dae]: Unable to open file "package://kobuki_description/meshes/base.dae".
[ERROR] [1372368978.648982915]: Could not load model 'package://kobuki_description/meshes/base.dae' for link 'base_link': OGRE EXCEPTION(6:FileNotFoundException): Cannot locate resource package://kobuki_description/meshes/base.dae in resource group Autodetect or any other group. in ResourceGroupManager::openResource at /build/buildd/ogre-1.7.4+dfsg1/OgreMain/src/OgreResourceGroupManager.cpp (line 753)

[ERROR] [1372368978.649183353]: Could not load model 'package://kobuki_description/meshes/base.dae' for link 'base_link': OGRE EXCEPTION(6:FileNotFoundException): Cannot locate resource package://kobuki_description/meshes/base.dae in resource group Autodetect or any other group. in ResourceGroupManager::openResource at /build/buildd/ogre-1.7.4+dfsg1/OgreMain/src/OgreResourceGroupManager.cpp (line 753)

[rviz-1] process has died [pid 13153, exit code -11, cmd /opt/ros/groovy/lib/rviz/rviz -d /opt/ros/groovy/stacks/turtlebot_viz/turtlebot_rviz_launchers/rviz/robot.rviz __name:=rviz __log:=/home/justyn/.ros/log/f1d3b6d8-df6e-11e2-a8cb-446d57eca273/rviz-1.log].
log file: /home/justyn/.ros/log/f1d3b6d8-df6e-11e2-a8cb-446d57eca273/rviz-1*.log
all processes on machine have died, roslaunch will exit
shutting down processing monitor...
... shutting down processing monitor complete
done

I am using a Turtlebot 2 with a Kobuki base and Kinect sensor. I have installed the full desktop installation of Groovy in Ubuntu and I am able to get a result from "rostopic list" so my connection to the Turtlebot from my workstation is working. Can anyone point me to the fix for this?

Thanks in advance!

EDIT: My apologies for the many postings, the Ask Your Question page kept giving me a 504 Gateway Timeout that did not confirm my question had been submitted. Once again sorry!

edit retag flag offensive close merge delete

Comments

I still have the problem on the workstation I was using, I've since switched to a different workstation (physically different) with the same install and it worked.

JHarriman gravatar image JHarriman  ( 2013-07-15 08:05:29 -0500 )edit

Hi, I also encountered the same problem. Since I bought a complete set of turtlebot, which means it comes with a pre-installed ROS on turtlebot netbook (Asus), I found that I could load rviz with a correct turtlebot model on the netbook, but on the workstation I got the error message and could only see the model of Kinect. Therefore, I tried to find the difference. Here is what I found: 1. in /opt/ros/groovy/stacks/kobuki_description/meshes: turtlebot netbook: there are base.dae and wheel.dae workstation: there are main_body.dae and wheel.dae 2. If I copied base.dae to the directory on turtlebot netbook, there would be no error message and the kobuki base model showed, but in a very small scale. I guess the setups in base.dae and in main_body.dae are quite different. Is this because of two different versions of view_model.launch ...(more)

kevinma gravatar image kevinma  ( 2013-08-04 17:01:21 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
3

answered 2013-08-06 16:26:03 -0500

Daniel Stonier gravatar image

Sounds like you have different versions of the debs on both turtlebot and workstation. Make sure you have the same versions.

There was also a change in the way rviz handles the meshes midway through groovy that wasn't ideal - introduced a breaking change in the way it handled scaling of the meshes. We updated the kobuki meshes to be compatible and I suspect that's where you're seeing the differences here.

Anyway, update and let us know how you fare.

edit flag offensive delete link more

Comments

Thank you, Daniel. Yes. It turns out that the pre-installed versions of the ROS debs on the Asus netbook coming from Yujin Robot are old, which I got in July, and the versions I installed on my workstation are new. After I installed turtlebot debs again on the turtlebot netbook, it works fine now. By the way, I have hydro + raring on the workstation and groovy + precise on the turtlebot. When I load rviz on the workstation, some error messages show like: Skipping XML Document "/opt/ros/hydro/share/rviz_python_tutorial/plugin_description.xml" which had no Root Element. This likely means the XML is malformed or missing. However, it doesn't seem to affect the rviz window display and performance.

kevinma gravatar image kevinma  ( 2013-08-07 22:26:29 -0500 )edit

Probably want to avoid mixing groovy and hydro. When turtlebot hydro is ready (very close), it's probably a good idea to upgrade that one.

Stonier@Yujin Robot gravatar image Stonier@Yujin Robot  ( 2013-08-07 23:17:04 -0500 )edit

As kevinma said, I had the same issue with pre-installed debs on the Asus netbook. I have since updated and everything works fine.

JHarriman gravatar image JHarriman  ( 2013-08-16 09:37:38 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-06-28 04:14:45 -0500

Seen: 3,675 times

Last updated: Aug 06 '13