Pr2 makes Gazebo crash with Illegal Instruction [closed]

asked 2013-05-23 06:05:56 -0600

Erwan R. gravatar image

updated 2014-11-22 17:05:39 -0600

ngrennan gravatar image

Hello,

As I didn't get any answer on Gazebosim, I'm addressing there my issue as it become very annoying and I can't stay without a functional ROS+Gazebo. I copied/pasted the post below :

Under ROS Fuerte and Ubuntu 10.04, I roslaunch empty_world environment with empty_world.launch. Everything looks right at this time. Then, I try to spawn the PR2 through "pr2.launch" file. The PR2 visually appears, but at some point, Gazebo crashes and PR2 node (default_controllers_spawner) also. I still got the Gazebo GUI and can manipulate the robot (move it in the environment) but I can't spawn other objects neither control the PR2. The error I get from Gazebo is an "Illegal Instruction" (logs are enclosed at the bottom of the question). On answers.ros.org, I found that a similar issue was due to SSE compilation process, but that may have been solved with Gazebo 1.6.15 (I'm using 1.6.16). Here I read about a Graphical Card driver that was conflicting ( http://answers.gazebosim.org/question/658/gazebo-pr2-getting-stuck-at-launch/ ) but as it is a ROS Groovy issue and my Gazebo is launching well, I'm not sure it can apply. I updated Linux with the recommended updates and ros with the corresponding patches on the beginning of May. As I didn't used ROS since Monday 6th, that may be part of the explanation.

Does somebody have an idea of what's going wrong with PR2 ? I can still spawn simple boxes in the environment. Thanks for reading !

EDIT of May, 27th '13 : I just downgraded to the previous electric version I was working with before, and the problem doesn't seem to appear. But that's no more than a cautery on a wooden leg and definitely not a solution, so any advice/help is still welcome. :)

Here are the logs :

renaudo@oogawa:~/ros_workspace$ roslaunch gazebo_worlds empty_world.launch

... logging to /home/renaudo/.ros/log/2436093a-bcad-11e2-be80-002219119be4/roslaunch-oogawa-19565.log
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

started roslaunch server http://oogawa:38763/

SUMMARY
========

PARAMETERS
 * /rosdistro
 * /rosversion
 * /use_sim_time

NODES
  /
    gazebo (gazebo/gazebo)
    gazebo_gui (gazebo/gui)

ROS_MASTER_URI=http://localhost:11311

core service [/rosout] found
process[gazebo-1]: started with pid [19585]
process[gazebo_gui-2]: started with pid [19592]
Gazebo multi-robot simulator, version 1.0.2
Copyright (C) 2011 Nate Koenig, John Hsu, Andrew Howard, and contributors.
Released under the Apache 2 License.
http://gazebosim.org

Gazebo multi-robot simulator, version 1.0.2
Copyright (C) 2011 Nate Koenig, John Hsu, Andrew Howard, and contributors.
Released under the Apache 2 License.
http://gazebosim.org

Msg Waiting for master.Msg Waiting for master
Msg Connected to gazebo master @ http://kingawa:11345
[ INFO] [1368622405.869056587]: waitForService: Service [/gazebo/set_physics_properties] has not been advertised, waiting...
[ INFO] [1368622406.697629250]: joint trajectory plugin missing <updateRate>, defaults to 0.0 (as fast as possible)

Msg Connected to gazebo master @ http://kingawa:11345
[ INFO] [1368622408.102870776, 0 ...
(more)
edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by tfoote
close date 2015-10-26 13:33:29.510358

Comments

Are you using 32-bit or 64-bit Ubuntu? Which processor do you have?

ahendrix gravatar imageahendrix ( 2013-05-23 08:24:38 -0600 )edit

My Ubuntu is 64-bit, my processors (2 cores) are Intel(R) Core(TM)2 Duo CPU E8500 @ 3.16GHz. I had no issue previously and Fuerte worked quite well before beginning of May.

Erwan R. gravatar imageErwan R. ( 2013-05-23 21:48:59 -0600 )edit