ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

PCL not being built with rosmake

asked 2013-05-22 06:18:21 -0500

Albatross gravatar image

updated 2013-06-27 18:17:45 -0500

130s gravatar image

I'm trying to build ROS fuerte on my debian sid/jessie machine. I'm compiling from source as the apt-get stuff doesn't work for me. Pretty much everything runs fine except packages that depend on the PCL package. When I try to build the gazebo_plugins with rosmake, I get an error like the one below:

  mkdir -p bin
  cd build && cmake -Wdev -DCMAKE_TOOLCHAIN_FILE=`rospack find rosbuild`/rostoolchain.cmake  ..
  [rosbuild] Building package gazebo_plugins
  Failed to invoke /opt/ros/fuerte/bin/rospack deps-manifests gazebo_plugins
  [rospack] Error: package/stack gazebo_plugins depends on non-existent package pcl

  CMake Error at /opt/ros/fuerte/share/ros/core/rosbuild/public.cmake:129 (message):

    Failed to invoke rospack to get compile flags for package 'gazebo_plugins'.
    Look above for errors from rospack itself.  Aborting.  Please fix the
    broken dependency!

  Call Stack (most recent call first):
    /opt/ros/fuerte/share/ros/core/rosbuild/public.cmake:203 (rosbuild_invoke_rospack)
    CMakeLists.txt:4 (rosbuild_init)

  -- Configuring incomplete, errors occurred!

I tried doing rosmake on perception_pcl, but ended up with this error:

  mkdir -p bin
  cd build && cmake -Wdev -DCMAKE_TOOLCHAIN_FILE=`rospack find rosbuild`/rostoolchain.cmake  ..
  [rosbuild] Building package pcl_ros
  [rosbuild] Including /opt/ros/fuerte/share/roscpp/rosbuild/roscpp.cmake
  [rosbuild] Including /opt/ros/fuerte/share/roslisp/rosbuild/roslisp.cmake
  [rosbuild] Including /opt/ros/fuerte/share/rospy/rosbuild/rospy.cmake
  -- [rosbuild] Found SSE3 extensions, using flags: -msse3 -mfpmath=sse
  CMake Error at CMakeLists.txt:21 (find_package):
    By not providing "FindPCL.cmake" in CMAKE_MODULE_PATH this project has
    asked CMake to find a package configuration file provided by "PCL", but
    CMake did not find one.

    Could not find a package configuration file provided by "PCL" with any of
    the following names:


    Add the installation prefix of "PCL" to CMAKE_PREFIX_PATH or set "PCL_DIR"
    to a directory containing one of the above files.  If "PCL" provides a
    separate development package or SDK, be sure it has been installed.

  -- Configuring incomplete, errors occurred!

It seems like there is a cmake file missing? I did a grep of my system, and the files it mentions aren't anywhere. I also tried downloading the stand-alone pcl code from github, and these files still don't exist.

I feel like I am doing something wrong, but I am not sure how to fix it, any help would be greatly appreciated. I am new to ROS and fairly new to unix. Let me know if you need any more information. Thanks! :)

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2013-06-30 01:47:16 -0500

Devasena Inupakutika gravatar image

The above issue during perception_pcl make was due to recent updates to ROS fuerte. I too faced this problem but on June 21 or the week before that, the issue related to PCL and ROS fuerte was resolved. Can you please trying building gazebo_plugins now ?

If re-making doesn't work. Then please do the following:

  1. Copy your perception_pcl package folder (entire folder) from /opt/ros/fuerte/stacks/ location to fuerte_workspace/sandbox.

  2. Don't forget to update this path in the ROS_PACKAGE_PATH.

  3. Then try rosmake perception_pcl and finally your gazebo_plugins.

Hope this helps !!

edit flag offensive delete link more

Question Tools


Asked: 2013-05-22 06:18:21 -0500

Seen: 1,039 times

Last updated: Jun 30 '13