Ask Your Question
0

roscore crashing after automatic update

asked 2013-04-09 04:09:59 -0500

Claudio gravatar image

updated 2014-04-20 14:09:25 -0500

ngrennan gravatar image

I just sudo apt-get updated my fuerte installation and roscore now crashes.

Here is the message

auto-starting new master
process[master]: started with pid [4443]
Traceback (most recent call last):
  File "/opt/ros/fuerte/bin/rosmaster", line 35, in <module>
    rosmaster.rosmaster_main()
  File "/usr/local/lib/python2.7/dist-packages/ros_comm-1.8.12-py2.7.egg/rosmaster/main.py", line 73, in rosmaster_main
    configure_logging()   
  File "/usr/local/lib/python2.7/dist-packages/ros_comm-1.8.12-py2.7.egg/rosmaster/main.py", line 57, in configure_logging
    _log_filename = rosgraph.roslogging.configure_logging('rosmaster', logging.DEBUG, filename=filename)
  File "/usr/local/lib/python2.7/dist-packages/ros_comm-1.8.12-py2.7.egg/rosgraph/roslogging.py", line 104, in configure_logging
    logging.config.fileConfig(config_file, disable_existing_loggers=False)
  File "/usr/lib/python2.7/logging/config.py", line 78, in fileConfig
    handlers = _install_handlers(cp, formatters)
  File "/usr/lib/python2.7/logging/config.py", line 153, in _install_handlers
    klass = _resolve(klass)
  File "/usr/lib/python2.7/logging/config.py", line 94, in _resolve
    __import__(used)
ImportError: No module named RosStreamHandler
[master] process has died [pid 4443, exit code 1, cmd rosmaster --core -p 11311 __log:=/home/erupter/.ros/log/bce1000e-a11e-11e2-aa7b-e0cb4e8e9c06/master.log].
log file: /home/erupter/.ros/log/bce1000e-a11e-11e2-aa7b-e0cb4e8e9c06/master*.log
ERROR: could not contact master [http://FCD-04-Ubuntu:11311/]

Log files are all empty.

I tried removing and reinstalling ros but it didn't work.

Seen this other question but it's the other way around for me and besides being on 12.04 LTS, I can't even do a dist-upgrade.

Also tried this (recreating the workspace) but it didn't do anything.

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
1

answered 2013-04-09 04:15:37 -0500

These are the (exact) same symptoms I experienced in groovy a few days ago (see Q/A). Have you tried the "dist-upgrade" option?

edit flag offensive delete link more

Comments

Tried, dist-upgrade won't do anything on my machine (I suppose 12.04 LTS can't be dist-upgraded until another LTS come out).

Claudio gravatar image Claudio  ( 2013-04-09 04:27:09 -0500 )edit

dist-upgrade does not change what distribution you are on. It is simply a command which allows apt to install new dependencies, which is forbidden in a standard upgrade.

tfoote gravatar image tfoote  ( 2013-06-17 17:40:01 -0500 )edit
1

answered 2013-04-09 04:36:29 -0500

mthz gravatar image

updated 2013-04-09 04:38:33 -0500

looks similar to this question: http://answers.ros.org/question/59644/rostopic-and-other-commands-fail-after-upgrade (rostopic and other commands fail after update)

edit flag offensive delete link more

Comments

No held upgrades here.

Claudio gravatar image Claudio  ( 2013-04-09 05:05:12 -0500 )edit

have you tried manual "sudo apt-get install ros-groovy-rosgraph" ?

mthz gravatar image mthz  ( 2013-04-09 05:17:07 -0500 )edit

As I said I have to stay on fuerte. I'm working with Pandaboards and getting groovy on them has been nigh impossible.

Claudio gravatar image Claudio  ( 2013-04-09 05:55:55 -0500 )edit

also the same as this un-answered thread http://answers.ros.org/question/60074/roscore-fails-to-start/

inflo gravatar image inflo  ( 2013-04-09 05:56:06 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-04-09 04:09:59 -0500

Seen: 340 times

Last updated: Apr 09 '13