Ask Your Question
2

Unable to contact my own XML-RPC server

asked 2011-03-06 07:36:07 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

Hi everyone,

after an upgrade of my Fedora system (now version 14) and a reinstall of ROS I tryed to start roscore but I got following message all the time:

[eos@poseidonius Documents]$ roscore

... logging to /home/eos/.ros/log/41d3b050-4838-11e0-95f3-0024d71f2bbc/roslaunch-poseidonius-13240.log Checking log directory for disk usage. This may take awhile. Press Ctrl-C to interrupt Done checking log file disk usage. Usage is <1GB.

Unable to contact my own XML-RPC server, this is a highly unusual error and should be reported immediately. My URI is [http://poseidonius:45166/]

Just some variable checks according to other questions found in the internet:

  1. echo $ROS_HOST (empty but set to) poseidonius

  2. echo $ROS_IP (empty but set correct) 192.168.178.31

  3. echo $ROS_MASTER_URI ( http://localhost:11311 set to) http://poseidonius:11311

What I have to do?

edit retag flag offensive close merge delete

Comments

With your "echo $ROS_*", what exactly do you mean by "empty but set..."? Do you set them before running roscore? Do you mean they are empty and the values listed are what you expect? The values listed are the values for your computer?
Eric Perko gravatar image Eric Perko  ( 2011-03-06 14:41:01 -0500 )edit
Hi Eric, yes, you are right. The values in branches are the ROS "default" values on my computer. After some websites I changed them to the second ones ...
Poseidonius gravatar image Poseidonius  ( 2011-03-06 16:41:41 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2011-03-06 17:38:47 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

Assuming your IP address is 192.168.178.31, a quick fix would be to execute the following before attempting to start a roscore:

export ROS_HOSTNAME=192.168.178.31
export ROS_IP=192.168.178.31
export ROS_MASTER_URI=http://192.168.178.31:11311

If that works lets roscore startup, then we can work backwards to find the exact problem spot.

Also, if you haven't seen it already, you may also want to take a look at the Network Setup page on the wiki.

As @kwc pointed out in the comments, this configuration will be very sensitive to changes in your current IP address. A more stable configuration for permanent use would be

export ROS_HOSTNAME=localhost
export ROS_MASTER_URI=http://localhost:11311

However, if your networking configuration is currently in a very bad state, localhost may not resolve to an IP address (or an incorrect IP address). Using bare IP addresses as in the first configuration chunk will get your around any problems in hostname resolution that you may be experiencing and provide a good place to start tracking down your networking issues.

edit flag offensive delete link more

Comments

Hi Eric, thanks for your help and patient ... using your suggested configuration it works fine !
Poseidonius gravatar image Poseidonius  ( 2011-03-06 17:53:51 -0500 )edit
I make some experiments, something seems to be wrong with my network configuration ... I will find the fault. Thanks again
Poseidonius gravatar image Poseidonius  ( 2011-03-06 17:57:27 -0500 )edit
In order to have a more stable configuration, I would probably try ROS_HOSTNAME=localhost, ROS_MASTER_URI=http://localhost:11311 . FYI: there is no need to set both ROS_HOSTNAME and ROS_IP. Just one is fine.
kwc gravatar image kwc  ( 2011-03-06 18:20:50 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2011-03-06 07:36:07 -0500

Seen: 2,301 times

Last updated: Mar 07 '11