Ask Your Question
0

Missing dependency roscpp?

asked 2011-02-20 13:25:20 -0500

updated 2011-02-20 14:09:40 -0500

Eric Perko gravatar image

" [rosbuild] Building package veltrobot_movement Failed to invoke /opt/ros/cturtle/ros/bin/rospack deps-manifests veltrobot_movement [rospack] couldn't find dependency [roscpp] of [veltrobot_movement] [rospack] missing dependency " How can I fix this?

http://www.ros.org/wiki/cturtle/Insta... I used this tutorial to install.

edit retag flag offensive close merge delete

Comments

How did you install ROS? Debs? Did you setup your .bashrc properly?
Eric Perko gravatar image Eric Perko  ( 2011-02-20 13:40:53 -0500 )edit
Can you list the exact command you are trying to use to build veltrobot_movement?
Eric Perko gravatar image Eric Perko  ( 2011-02-20 13:41:19 -0500 )edit
"rosmake veltrobot_teleop veltrobot_movement robot_state_publisher rviz" http://www.ros.org/wiki/cturtle/Installation/Ubuntu I used that tutorial to install.
GeniusGeeko gravatar image GeniusGeeko  ( 2011-02-20 14:00:18 -0500 )edit
Can you include the output of 'rosmake --rosdep-install roscpp'?
Eric Perko gravatar image Eric Perko  ( 2011-02-20 14:10:45 -0500 )edit
[rosmake ] Packages requested are: ['roscpp'] [ rosmake ] Logging to directory/home/geniusgeeko/.ros/rosmake/rosmake_output-20110220-212109 [ rosmake ] Expanded args ['roscpp'] to: ['roscpp'] [ rosmake ] Generating Install Script using rosdep then executing. This may take a minute, you will be prompted for permissions. . . executing this script: set -o errexit #No Packages to install [ rosmake ] rosdep successfully installed all system dependencies [rosmake-0] Starting >>> roslang [ make ] [rosmake-0] Finished <<< roslang ROS_NOBUILD in package roslang No Makefile in package roslang [rosmake-1] Starting >>> roslib [ make ] [rosmake-1] Finished <<< roslib ROS_NOBUILD in package roslib [rosmake-0] Starting >>> xmlrpcpp [ make ] [rosmake-0] Finished <<< xmlrpcpp ROS_NOBUILD in package xmlrpcpp [rosmake-1] Starting >>> rosconsole [ make ] [rosmake-1] Finished <<< rosconsole ROS_NOBUILD in package rosconsole [rosmake-1] Starting >>> roscpp [ make ] [rosmake-1] Finished <<< roscpp ROS_NOBUILD in package roscpp [rosmake-1] Starting >>> rosout [ make ] [rosmake-1] Finished <<< rosout ROS_NOBUILD in package rosout [ rosmake ] Results: [ rosmake ] Built 8 packages with 0 failures. [ rosmake ] Summary output to directory [ rosmake ] /home/geniusgeeko/.ros/rosmake/rosmake_output-20110220-212109
GeniusGeeko gravatar image GeniusGeeko  ( 2011-02-20 14:21:10 -0500 )edit
^ Restarted terminal and got. However when trying to build the veltrobot, now I'm getting missing dependency openni. When i run ~/ni/setup.sh , I get the roscpp error but not the openni error.
GeniusGeeko gravatar image GeniusGeeko  ( 2011-02-20 14:22:52 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2011-02-20 14:44:25 -0500

Conflicting packages... the problem was that when the terminal started it would cturtle/setup.bash then ~/ni/setup.sh the setup.sh would set the ROSROOT to the unstable and get rid of the veltrop packet list from the ROS_PACKAGE_PATH. When adding the veltrop package to the PATH it would rid of the OPENNI package path. When running the ~/ni/setup.sh it would bring me to the unstable which would render to a roscpp due to conflicting paths. Thanks for the help.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-02-20 13:25:20 -0500

Seen: 2,048 times

Last updated: Feb 20 '11