Ask Your Question
0

Gazebo stuck waiting for Master in Groovy

asked 2013-02-28 11:15:40 -0600

rtoris288 gravatar image

I am attempting to run the latest public Groovy gazebo build under Ubuntu 12.04, but the process hangs waiting for the master:

    tor1pal@thror:groovy$ roslaunch gazebo_worlds empty_world.launch 
... logging to /home/tor1pal/.ros/log/a3bb5152-81fb-11e2-b3dc-78acc0be2023/roslaunch-thror-4864.log
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

started roslaunch server http://thror:52847/

SUMMARY
========

PARAMETERS
 * /rosdistro
 * /rosversion
 * /use_sim_time

NODES
  /
    gazebo (gazebo/gazebo)
    gazebo_gui (gazebo/gui)

auto-starting new master
process[master]: started with pid [4878]
ROS_MASTER_URI=http://localhost:11311

setting /run_id to a3bb5152-81fb-11e2-b3dc-78acc0be2023
process[rosout-1]: started with pid [4891]
started core service [/rosout]
process[gazebo-2]: started with pid [4905]
process[gazebo_gui-3]: started with pid [4916]
Gazebo multi-robot simulator, version 1.3.0
Copyright (C) 2012 Nate Koenig, John Hsu, and contributors.
Released under the Apache 2 License.
http://gazebosim.org

Gazebo multi-robot simulator, version 1.3.0
Copyright (C) 2012 Nate Koenig, John Hsu, and contributors.
Released under the Apache 2 License.
http://gazebosim.org

Warning [parser.cc:361] Converting a deprecated SDF source[/opt/ros/groovy/stacks/simulator_gazebo/gazebo_worlds/worlds/empty.world].
Set SDF value
  Version[1.2] to Version[1.3]
  Please use the gzsdf tool to update your SDF files.
    $ gzsdf convert [sdf_file]
Msg Waiting for master.[ INFO] [1362092857.805255296]: waitForService: Service [/gazebo/set_physics_properties] has not been advertised, waiting...
Msg Waiting for master...................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................

Any thoughts?

edit retag flag offensive close merge delete

Comments

can you post the results of these commands: 'ifconfig' and 'env | grep ROS' There seems to be a mismatch between the roslaunch server and your master uri. IIRC this will be a problem

weiin gravatar imageweiin ( 2013-02-28 13:11:02 -0600 )edit

Did you find out what caused this yet? I am having the same problems at the moment.

Hansg91 gravatar imageHansg91 ( 2013-03-02 12:03:15 -0600 )edit

Hi, I have the same problem. Did you solve it?

Robotnik gravatar imageRobotnik ( 2013-03-17 11:43:43 -0600 )edit

2 Answers

Sort by » oldest newest most voted
0

answered 2013-02-28 11:27:08 -0600

dcconner gravatar image

I've seen a similar problem if your network connection is unplugged.

Apparently ROS requires a live network port even if you're running everything on one machine (at least if you have an IP assigned to your hostname).

edit flag offensive delete link more

Comments

I do have a valid network connection (using the same machine to make this post :) ).

rtoris288 gravatar imagertoris288 ( 2013-02-28 11:30:32 -0600 )edit
0

answered 2013-04-16 00:25:04 -0600

For me, this solved the problem (removing "localhost" from the "::1" line of /etc/hosts).

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

3 followers

Stats

Asked: 2013-02-28 11:15:40 -0600

Seen: 889 times

Last updated: Apr 16 '13