Ask Your Question
1

SICK LMS500 connection and drivers

asked 2013-02-26 21:41:15 -0600

dkc gravatar image

updated 2014-01-28 17:15:26 -0600

ngrennan gravatar image

Hello everyone.

I would like to ask the ROS community, if anyone had any success on compiling a node or wrapper for the SICK LMS500 Lidar scanner. I have already examined the sicktoolbox and the links from adept robotics and github but still I can't receive any data from the scanner. Apparently the problem occurs because the LMS200 and LMS500 use different connection interfaces, RS232 & Ethernet respectively. Does anyone have any thoughts or experience to share regarding this scanner? My Os is Ubuntu 12.04 and my distro is Fuerte.

Thank you all in advance.

edit retag flag offensive close merge delete

Comments

Do you happen to have the Sick USB driver for the LMS5xx that comes on the CD with the scanner. We need it. Thanks.

TimElery gravatar imageTimElery ( 2014-01-23 15:14:23 -0600 )edit

did you get the problem solved?

romi gravatar imageromi ( 2018-05-02 03:06:06 -0600 )edit

4 Answers

Sort by » oldest newest most voted
3

answered 2013-02-27 17:45:10 -0600

Ryan gravatar image

We're currently using this repo fork (also on our github) to connect to an LMS511. Didn't need to do any kind of reconfiguration in the node or LIDAR aside from changing the IP of the LIDAR in the sicklms5xx.cpp file.

edit flag offensive delete link more

Comments

Thank you Ryan for the quick reply. I just wanted to ask if you connect the scanner directly to your PC with the Ethernet cable or via a switch. I have an error "ERROR: I/O Exception - SickLMS5xx::_setupConnection: socket error on connect()!" and I would appreciate your thoughts about this.

dkc gravatar imagedkc ( 2013-03-19 02:43:31 -0600 )edit

We usually use a switch, but I recall a direct connection works as well. You'll just need to make sure your PC IP is on the same subnet as the LIDAR. Also, the LIDAR may be set to DHCP by default. We work with so many LIDARs, I can't remember off hand (use SOPAS to reconfigure if it is).

Ryan gravatar imageRyan ( 2013-03-19 08:43:06 -0600 )edit

Do you happen to have the USB driver for the LMS5xx. We need it. Thanks.

TimElery gravatar imageTimElery ( 2014-01-23 15:13:45 -0600 )edit

For others who might be interested in how Tim & I solved his problem offline, you don't in fact need the USB driver. However, if you're building your own cable, you should wire it as per the pinout in the manual (https://mysick.com/saqqara/im0037514.pdf), not as a crossover.

Ryan gravatar imageRyan ( 2014-01-24 03:16:16 -0600 )edit

Thanks again Ryan!

TimElery gravatar imageTimElery ( 2014-01-24 13:36:44 -0600 )edit

@Ryan i get this error when i run the launch file ERROR: I/O exception - SickLMS5xx::_setupConnection: socket error on connect()! And also I'm connected over Ethernet...

Please help!

Aakash gravatar imageAakash ( 2016-12-07 09:09:58 -0600 )edit
0

answered 2013-02-27 15:22:11 -0600

Gav gravatar image

I'm not familiar with the LMS500, but if the protocol is the same as the LMS200, (just the physical interface is different) then you might be able to solve the problem by redirecting the serial data to ethernet. Netcat is good for this sort of thing: E.g. http://stackoverflow.com/questions/484740/converting-serial-port-data-to-tcp-ip-in-a-linux-environment

edit flag offensive delete link more
0

answered 2017-04-04 09:06:06 -0600

vik748 gravatar image

After trying a number of driver and packages for our SICK LMS511, the best one I found to work with my ROS Indigo installation was from https://github.com/pangfumin/lms511_l...

All I had to do was initialize a workspace, copy the folder laser_node into the src folder and then catkin_make. Hope this helps someone else.

Cheers, Vik

edit flag offensive delete link more

Comments

I m getting an error as described here http://answers.ros.org/question/26322... Could yolu solve it ?

sai gravatar imagesai ( 2017-06-06 02:18:52 -0600 )edit
0

answered 2013-03-07 10:23:10 -0600

ReedHedges gravatar image

It's (mostly) the same protocol as the LMS100, so the LMS1xx ros node may work (but I haven't had a chance to test it yet... I know that the lms1xx interface library that the LMS1xx ROS node uses was updated at some point to fix a bug to work with the lms500, not sure if that is in most recent LMS1xx ros node package.)

edit flag offensive delete link more

Comments

Didn't seem to work for us when we tried recently.

Ryan gravatar imageRyan ( 2013-03-07 12:41:01 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-02-26 21:41:15 -0600

Seen: 3,565 times

Last updated: Mar 07 '13