Ask Your Question
1

rosrun sicktoolbox_wrapper sicklms error

asked 2012-09-06 01:07:33 -0600

Ocean gravatar image

updated 2012-09-06 15:11:40 -0600

When i run the command "rosrun sicktoolbox_wrapper sicklms _port:=/dev/ttyS0" on the Pioneer Powerbot,the terminal shows the error,and i had tried a lot of solutions on the internet,but those did not work.So hope your advice! note:ROS electric ;Ubuntu 11.10

root@ubuntu:~# rosrun sicktoolbox_wrapper sicklms _port:=/dev/ttyS0
    *** Attempting to initialize the Sick LMS...
    Attempting to open device @ /dev/ttyS0
        Device opened!
    Attempting to start buffer monitor...
        Buffer monitor started!
    Attempting to set requested baud rate...
A Timeout Occurred!  2 tries remaining
A Timeout Occurred!  1 tries remaining
A Timeout Occurred - SickLIDAR::_sendMessageAndGetReply: Attempted max number of tries w/o success!
    Failed to set requested baud rate...
    Attempting to detect LMS baud rate...
        Checking 19200bps...
A Timeout Occurred!  2 tries remaining
A Timeout Occurred!  1 tries remaining
A Timeout Occurred - SickLIDAR::_sendMessageAndGetReply: Attempted max number of tries w/o success!
        Checking 38400bps...
A Timeout Occurred!  2 tries remaining
A Timeout Occurred!  1 tries remaining
A Timeout Occurred - SickLIDAR::_sendMessageAndGetReply: Attempted max number of tries w/o success!
        Checking 500Kbps...
A Timeout Occurred!  2 tries remaining
A Timeout Occurred!  1 tries remaining
A Timeout Occurred - SickLIDAR::_sendMessageAndGetReply: Attempted max number of tries w/o success!
ERROR: I/O exception - SickLMS::Initialize: failed to detect baud rate!
[ERROR] [1346919668.935157216]: Initialize failed! are you using the correct device path?
edit retag flag offensive close merge delete

Comments

1

Are you using the correct device path? What does ls /dev/ttyS* give?

jbohren gravatar imagejbohren ( 2012-09-09 01:34:09 -0600 )edit

1 Answer

Sort by » oldest newest most voted
1

answered 2012-09-09 06:47:51 -0600

allenh1 gravatar image

The issue is the fact that the laser takes its time when starting up. You need to set a 30 second delay...

If you need further assistance, don't hesitate to ask.

edit flag offensive delete link more

Comments

Please, how to set delay to 30 seconds? Thanks.

Fábio Silveira Vidal gravatar imageFábio Silveira Vidal ( 2013-06-25 03:47:43 -0600 )edit

Hi, @allenh1 I m getting error as shown here ? You know how to solve ? http://answers.ros.org/question/26322...

sai gravatar imagesai ( 2017-06-06 02:02:18 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2012-09-06 01:07:33 -0600

Seen: 1,037 times

Last updated: Sep 09 '12