Ask Your Question
0

sicklms failed to initialized:failed to detect baud rate!

asked 2011-11-20 14:19:32 -0600

sven_007 gravatar image

updated 2011-11-21 03:06:16 -0600

joq gravatar image
*** Attempting to initialize the Sick LMS...
Attempting to open device @ /dev/ttyMXUSB0
    Device opened!
Attempting to start buffer monitor...
    Buffer monitor started!
Attempting to set requested baud rate...
A Timeout Occurred!  2 tries remaining
A Timeout Occurred!  1 tries remaining
A Timeout Occurred - SickLIDAR::_sendMessageAndGetReply: Attempted max number of tries w/o success!
Failed to set requested baud rate...
Attempting to detect LMS baud rate...
    Checking 19200bps...
A Timeout Occurred!  2 tries remaining
A Timeout Occurred!  1 tries remaining
A Timeout Occurred - SickLIDAR::_sendMessageAndGetReply: Attempted max number of tries w/o success!
    Checking 38400bps...
A Timeout Occurred!  2 tries remaining
A Timeout Occurred!  1 tries remaining
A Timeout Occurred - SickLIDAR::_sendMessageAndGetReply: Attempted max number of tries w/o success!
    Checking 500Kbps...
A Timeout Occurred!  2 tries remaining
A Timeout Occurred!  1 tries remaining
A Timeout Occurred - SickLIDAR::_sendMessageAndGetReply: Attempted max number of tries w/o success!
ERROR: I/O exception - SickLMS::Initialize: failed to detect baud rate!
[ERROR] [1321844482.225130027]: Initialize failed! are you using the correct device path?
edit retag flag offensive close merge delete

6 Answers

Sort by » oldest newest most voted
0

answered 2011-11-30 13:09:35 -0600

sven_007 gravatar image

updated 2011-11-30 13:09:59 -0600

It worked after I set the interface of "/dev/ttyMXUSB0" to RS-422.

Thank goodness!

edit flag offensive delete link more
0

answered 2012-08-22 03:07:51 -0600

Natália gravatar image

updated 2012-08-24 06:47:12 -0600

Hi,

I got the same error trying to connect my Sick laser and I found no solution. I have a USB->RS422 converter and it works fine with all baud rates equal or less than 38400. When I set the baud rate to 500000, then a similar error message appears. I tried some commands from the tutorial "Using The Sick lms" (http://www.ros.org/wiki/sicktoolbox_wrapper/Tutorials/UsingTheSicklms):

rosparam set sicklms/port /dev/ttyUSB0

rosparam set sicklms/baud 5000000

and

stty -F /dev/ttyUSB0 500000

rosrun sicktoolbox_wrapper sicklms _port:=/dev/ttyUSB0 _baud:=500000

Please help me to configure ROS parameters or something else, I really need that baud speed to work. My Sick is LMS291-S05.

Thanks!

Natália.

edit flag offensive delete link more

Comments

We have the same problem when set the baud rate to 500000.Have you sloved the problem?

sven_007 gravatar imagesven_007 ( 2012-10-30 16:37:15 -0600 )edit

I have the same problem too, I'm reviewing the player/stage driver sicklms200.cc and Upenn wrote a sicklms200b.cc that may work

jimbo gravatar imagejimbo ( 2013-05-26 16:55:22 -0600 )edit
0

answered 2011-11-21 03:32:12 -0600

dornhege gravatar image

Just a wild guess, but we needed to set the device to 500k manually like this:

setserial /dev/ttyS1 baud_base 500000 uart 16654

Other than that: "are you using the correct device path?" and what scanner is it?

edit flag offensive delete link more

Comments

The scanner I use is lms200 .And I use the Uport1250 to connect the laser.
sven_007 gravatar imagesven_007 ( 2011-11-21 11:13:29 -0600 )edit
0

answered 2013-10-14 16:57:11 -0600

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

RS-232 converter usb 2-1.2: FTDI USB Serial Device converter now attached to ttyUSB0.

it doesn't work with SICK2XX and pioneer robot on my ubuntu 12.04.

but - usb 1-1.2: ch341-uart converter now attached to ttyUSB1

it works fine. so, i guess problem with cable driver.

Try changing cable or finding appropriate driver.

edit flag offensive delete link more
0

answered 2014-04-01 07:50:38 -0600

bona gravatar image

During the initialization, the driver will try to auto detect the baud rate of the LIDAR(which stays the same as the last time it runs.) And as RS232 can do no more than 19200, may be you need to check with a RS422 connection.

Another thing is if you want your lidar to work at real-time, you definite need 500K baud rate.

edit flag offensive delete link more
0

answered 2012-01-05 11:11:08 -0600

discostews gravatar image

updated 2012-01-05 14:11:54 -0600

Hey,

I am having the same problem with my SICK laser. I can get it to work perfectly when using a USB->RS232 adapter (but with many of the "A scan was probably missed") messages.

However, to operate faster, I am trying to connect using an RS422 interface. The ports are showing up under /dev/ttyUSB1, /dev/ttyUSB2 etc. But I cannot get the SICK to communicate through these ports.

Sven_007 - what do you mean by "set the interface of "/dev/ttyMXUSB0" to RS-422"??

I am setting _baud:=500000 and have set the permissions on the port correctly. However, i end up with the same error messages as the original post.

Any ideas much appreciated!

Thanks,

S

edit flag offensive delete link more

Comments

I use the Uport1250 to connect the sick.Uport1250 is a USB to serial adapter.So after I connected them,it shows /dev/ttyMXUSB0 and /dev/ttyMXUSB1. Uport1250 can work on RS232 and RS422.I doubt whether your adapter support RS422.

sven_007 gravatar imagesven_007 ( 2012-02-16 15:27:06 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2011-11-20 14:19:32 -0600

Seen: 1,801 times

Last updated: Apr 01 '14