Ask Your Question
0

The problem of baud rate when using sicktoolbox_wrapper!

asked 2012-10-21 22:01:18 -0600

dllg_211 gravatar image

updated 2012-10-22 03:49:42 -0600

Hi, I am having a problem of baud rate with sick lms200 laser when using sicktoolbox_wrapper. I am using ubuntu 10.04 and ROS electric. I followed the tutorial on http://www.ros.org/wiki/sicktoolbox_wrapper/Tutorials/UsingTheSicklms

When I set the baud rate to be 38400: rosparam set sicklms/baud 38400.The laser works well,but there is a waring:

                A scan was probably missed.

However,when I set the baud rate to be 500000,the laser can't work ,of course ,the baud of laser is 500k.The error is as follow:

     Attempting to set requested baud rate...
A Timeout Occurred!  2 tries remaining
A Timeout Occurred!  1 tries remaining
A Timeout Occurred - SickLIDAR::_sendMessageAndGetReply: Attempted max number of tries w/o success!
    Failed to set requested baud rate...
    Attempting to detect LMS baud rate...
        Checking 19200bps...
A Timeout Occurred!  2 tries remaining
A Timeout Occurred!  1 tries remaining
A Timeout Occurred - SickLIDAR::_sendMessageAndGetReply: Attempted max number of tries w/o success!
        Checking 38400bps...
A Timeout Occurred!  2 tries remaining
A Timeout Occurred!  1 tries remaining
A Timeout Occurred - SickLIDAR::_sendMessageAndGetReply: Attempted max number of tries w/o success!
        Checking 500Kbps...
A Timeout Occurred!  2 tries remaining
A Timeout Occurred!  1 tries remaining
A Timeout Occurred - SickLIDAR::_sendMessageAndGetReply: Attempted max number of tries w/o success!
ERROR: I/O exception - SickLMS::Initialize: failed to detect baud rate!
[ERROR] [1346919668.935157216]: Initialize failed! are you using the correct device path?

Is someone using the sicklms200 with the baud rate of 500k well? Maybe you can give me some advices! Thanks in advance!

edit retag flag offensive close merge delete

Comments

Attempting to sync driver...
    Driver synchronized!
*** Init. complete: Sick LMS is online and ready!
Sick Type: Sick LMS 291-S14
Scan Angle: 90 (deg)
Scan Resolution: 0.5 (deg)
Measuring Mode: 8m/80m; 3 reflector bits
Measuring Units: Centimeters (cm)
jimbo gravatar imagejimbo ( 2013-05-08 14:49:41 -0600 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2013-11-06 05:13:48 -0600

Cássio gravatar image

Hello,

Try to update the baud rate to 19200 and after change to 38400 again. It solved to me.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-10-21 22:01:18 -0600

Seen: 743 times

Last updated: Nov 06 '13