ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

MoveIt Rviz "No planning library loaded"

asked 2013-01-30 07:08:51 -0500

viovio gravatar image

updated 2013-03-06 03:30:42 -0500

Hello to all,

after finishing the "MoveIt! Setup Assistant" for my tx60l-robot I tried to start the rviz moveit plugin with following command:

roslaunch tx60l_moveit moveit_rviz.launch

Rviz starts, but there is no robot visible.

The "moveit_rviz.launch"-file generated by the "MoveIt! Setup Assistant":


  <arg name="debug" default="false" />
  <arg unless="$(arg debug)" name="launch_prefix" value="" />
  <arg     if="$(arg debug)" name="launch_prefix" value="gdb --ex run --args" />

  <node name="$(anon rviz)" launch-prefix="$(arg launch_prefix)" pkg="rviz" type="rviz" respawn="false" output="screen">
    <rosparam command="load" file="$(find tx60l_moveit_config)/config/kinematics.yaml"/>


There is no reference on my .urdf-file I used for the MoveIt! Setup Assistant" ! -> no robot can be displayed

Though this instruction shows a different kind of .launch-file (using pr2-robot):

        <include file="$(find pr2_description)/robots/upload_pr2.launch"/>
        <node pkg="tf" type="static_transform_publisher" name="odom_broadcaster" args="0 0 0 0 0 0 odom_combined base_footprint 100" />
        <node name="joint_state_publisher" pkg="joint_state_publisher" type="joint_state_publisher">
         <param name="/use_gui" value="false"/>
        <node name="robot_state_publisher" pkg="robot_state_publisher" type="robot_state_publisher" respawn="true" output="screen" />
        <node name="joint_state_publisher" pkg="joint_state_publisher" type="joint_state_publisher">
           <param name="/use_gui" value="false"/>
        <include file="$(find pr2_moveit_config)/launch/moveit_rviz.launch"/>

My new launch file:

    <include file="$(find tx60l_moveit)/launch/upload_tx60l.launch"/>
    <include file="$(find tx60l_moveit)/launch/moveit_rviz.launch"/>


    <param name="robot_description" command="cat $(find learning_urdf)/tx60l.xml" />


With my new launch-file Rviz starts finally. Obviously all nodes are loaded by the Moveit Assistant generated launch file (Though I cant detect them in there)

After starting Rviz I add "MotionPlanning" like described in this tutorial. Now my Robot is visible

But there is the hint: "no planning library loaded". Have I to start Rviz with an additional parameter which defines the used planning library?

Also I cant select any "Planning Group"!

How can I solve that? Or what information are relevant to help me?


Now the OMPL is loaded, thx to Boris. But I dont get any interactive marker (is there a different way to set robot-poses?) for my robot-arm when I click on "Interact". When I load the pr2-demo it works. So the failure has to be hidden in my robot-config created with the "Setup Assistant". Is it because I didnt have defined an End-Effector?

Edit: Dave told me the problem is the end-effector. But I still cant solve it. I already tried all combinations. My robot is a simple arm of 6 links connected by 5 joints. I put all joints in one "arm-group" and the last link (link6) in another group called "end" but with no ki-solver, because its only one link. I think that's similar to this tutorial. Then I added an end-effector with the end-effector-group "end" and the parent link link 5. But there is still no interactive markers visible. What am I doing wrong?

Many Thanks in advance viovio

edit retag flag offensive close merge delete


Please do not modify your questions that much. It is very difficult to track the changes. If you have new info simply add it under section "Edit", including the modified versions of your files. For very long (more than one screen) logs please consider PasteBin.

Boris gravatar image Boris  ( 2013-02-06 23:35:58 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted

answered 2013-02-06 00:53:13 -0500

Not sure if it is a real cause of the problem, but you have duplicated joint_state_publisher node in your config.

Also, if understand correctly, TX60L is an industrial manipulator from Staubli that is supposed to be fixed, e.g to a floor. So in case you are not going to put it on wheels in your simulation you don't need odometry frame. Thus a more relevant tutorial for you would be the one from ROS Industrial. There is a reference to demo.launch template where you should specify the name of your MoveIt generated package.

So, for example, I have the following demo.launch for Schunk LWA manipulator:

  <param name="robot_description" textfile="$(find lwa_moveit_config)/config/lwa.urdf" />
  <node name="joint_state_publisher" pkg="joint_state_publisher" type="joint_state_publisher">
    <param name="/use_gui" value="false"/>
  <node name="robot_state_publisher" pkg="robot_state_publisher" type="robot_state_publisher" />
  <include file="$(find lwa_moveit_config)/launch/move_group.launch">
    <arg name="allow_trajectory_execution" value="false"/>
  <include file="$(find lwa_moveit_config)/launch/moveit_rviz.launch"/>

Hope it helps,


edit flag offensive delete link more


Thank you for your answer Boris. Meanwhile I solved my problem particulate (See my post). Unfortunately rviz loads no motion planing library.

viovio gravatar image viovio  ( 2013-02-06 23:23:07 -0500 )edit

Please try the proposed launch file (don't forget to make changes according to your work environment). The one you are using now does not utilize planner, i.e. move_group.launch and of course there is no planning groups.

Boris gravatar image Boris  ( 2013-02-06 23:39:37 -0500 )edit

Thx Boris, after adding it works. But I get no interactive markers after clicking on Interact.

viovio gravatar image viovio  ( 2013-03-06 00:34:12 -0500 )edit

I'm having the same issue at the moment, planning works though. Also my case is 7-DOF arm with several additional fixed links and custom IKFast solver. So I'm unsure at the moment what causing this problem. Looks like some misconfiguration of planning groups in Setup Assistant.

Boris gravatar image Boris  ( 2013-03-06 17:31:38 -0500 )edit

Have you found a solution for the problem?

viovio gravatar image viovio  ( 2013-03-08 08:44:13 -0500 )edit

Not yet, it doesn't disturb me that much. However I did encounter this behaviour before and the issue was with non-complete configuration in MoveIt assistant, especially with the end-effector planning group. So if your arm has no gripper it can be the reason. Try to add a fake tool link in URDF.

Boris gravatar image Boris  ( 2013-03-08 22:51:15 -0500 )edit

answered 2013-02-19 05:11:17 -0500

Dave Coleman gravatar image

updated 2013-03-05 09:23:13 -0500

You need to launch YOURROBOT_moveit_config/launch/move_group.launch first, before running the rviz launcher.

The move_group.launch file starts up the planning pipeline necessary for the Motion Planning Plugin to do actual planning. Additionally, it will load your URDF file for you, no need to use upload_tx60l.launch.

Response to Edited Question: Yes, the interactive markers will not show up unless all the parameters to the end effector are setup correctly

edit flag offensive delete link more


I allready launch YOURROBOT_moveit_config/launch/move_group.launch first, before running the rviz launcher. Nethertheless I have to use upload_tx60l.launch, or I get the error that the urdf-file cant be found.

viovio gravatar image viovio  ( 2013-03-05 05:04:17 -0500 )edit

Ah, I see now in planning_context.launch that you need to change the first arg ("load_robot_description") to true. That should fix your problem

Dave Coleman gravatar image Dave Coleman  ( 2013-03-05 09:21:50 -0500 )edit

Yes, you're right. Thx. Do you also have a solution for my missing interactive marker - problem (see my last edit) ?

viovio gravatar image viovio  ( 2013-03-06 00:31:49 -0500 )edit

Hello. I want to start by saying that I am new to the Moveit programming. I have a Cyton gamma 1500 robot rm and I managed to make the arm move with Rviz. I created another group for the gripper but i couldn't make the gripper to read from Rviz onlt from controller.yaml. Can someone give me a hint?

Ioachim gravatar image Ioachim  ( 2015-03-16 04:44:16 -0500 )edit

Question Tools

1 follower


Asked: 2013-01-30 07:08:51 -0500

Seen: 8,002 times

Last updated: Mar 06 '13