ROS Resources: Documentation | Support | Discussion Forum | Service Status | Q&A answers.ros.org
Ask Your Question
0

openni doesn't find kinect

asked 2013-01-01 10:43:12 -0500

Oier gravatar image

updated 2016-10-24 09:02:36 -0500

ngrennan gravatar image

Hi,

I am running Ubuntu 12.10 and ROS Groovy.

lsusb shows the kinect:

Bus 002 Device 019: ID 045e:02ad Microsoft Corp. Xbox NUI Audio
Bus 002 Device 018: ID 045e:02b0 Microsoft Corp. Xbox NUI Motor
Bus 002 Device 020: ID 045e:02ae Microsoft Corp. Xbox NUI Camera

But when I run roslaunch openni_launch openni.launch, it doesn't find the kinect.

[ INFO] [1357079636.178559036]: No devices connected.... waiting for devices to be connected
[ INFO] [1357079639.179093142]: No devices connected.... waiting for devices to be connected

A week ago, after installing the updated openni package, everything worked and now I get the same "no devices connected" message even though I tried connecting it in different usb ports etc. Is this a bug or is my camera somehow broken?

Regards,

Oier

edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted
4

answered 2013-01-02 21:24:26 -0500

Oier gravatar image

Well, after trying everything from manually putting the devices id on the launcher file, to remove gspca_kinect (which wasn't loaded), I had the brilliant idea of reinstalling all the openni ros packages via synaptic, now it works :-)

edit flag offensive delete link more

Comments

I'm having similar issues and tried re-installing all the openni packages via synaptic, but when I went to re-install them it appears there are only 32bit version available at the moment. Did you have this problem? I'll try again tomorrow but it appears there is a debian issue.

Dave Coleman gravatar imageDave Coleman ( 2013-01-04 11:34:20 -0500 )edit

What version of Ubuntu are you using? I have 12.10 and the openni packages installed are 64 bits architecture.

Oier gravatar imageOier ( 2013-01-04 22:13:17 -0500 )edit

I'm on 12.04. The packages are available again - not sure if it was my computer or the servers.

Dave Coleman gravatar imageDave Coleman ( 2013-01-10 04:27:23 -0500 )edit

I updated on electric (ros-electric-openni-kinect (0.3.4-s1336532617~lucid => 0.3.6-s1356576176~lucid)) and it broke everything. I got the "No Device Connected" error, I reinstalled and it fixed it.

ben gravatar imageben ( 2013-02-04 11:29:50 -0500 )edit
0

answered 2013-01-02 17:27:53 -0500

jkammerl gravatar image

The recent kernel comes with a driver called gspca_kinect that could block the connection to the openni sensor. You should check if it gspca_kinect exists in your driver list and if so, try removing it with:

sudo modprobe -r gspca_kinect

edit flag offensive delete link more
0

answered 2013-01-02 10:50:12 -0500

dinamex gravatar image

Since the OS detected the sensor I would say the problem is caused by the package or some numerating issues. Did you change something in the launch file? maybe it wants to load a specific sensor with a given device_id. A solution would be to connect to a specific address if you didn't change something in the launch file so far.

See in the beginning of openni.launch

  <!-- device_id can have the following formats:
         "B00367707227042B": Use device with given serial number
         "#1"              : Use first device found
         "2@3"             : Use device on USB bus 2, address 3
         "2@0"             : Use first device found on USB bus 2
    -->
  <arg name="device_id" default="#1" />
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-01-01 10:43:12 -0500

Seen: 4,813 times

Last updated: Jan 02 '13