Ask Your Question
0

openni_camera.openni_node.launch won't start

asked 2011-03-09 01:54:23 -0500

tom gravatar image

updated 2016-10-24 08:59:57 -0500

ngrennan gravatar image

Hi,

On the beginning a list of similar, but slightly different issues: Issue1, Issue2, Issue3

I've installed Diamondback variant mobile from source a couple of days ago. Then I added image_transport, vision_opencv, perception_pcl_addons and ni. Everything compiled fine. After building openni_camera I tried to run roslaunch openni_camera openni_node.launch, but unfortunately the kinect node got killed everytime I tried this as I also documented here, as I thought this might be related.

Then I saw there is also a openni_kinect stack which includes openni_camera, so I downloaded and compiled this one instead of ni (and deleted ni). Unfortunately the whole thing is still not working, but the output is slightly different:

process[openni_node1-2]: started with pid [3221]
process[kinect_base_link-3]: started with pid [3226]
process[kinect_base_link1-4]: started with pid [3227]
process[kinect_base_link2-5]: started with pid [3236]
process[kinect_base_link3-6]: started with pid [3247]

[ INFO] [1299682836.033725620]: [/openni_node1] Number devices connected: 1
[ INFO] [1299682836.034331843]: [/openni_node1] 1. device on bus 001:31 is a Xbox NUI Camera (2ae) from Microsoft (45e) with serial id 'A00364814366047A'
[ INFO] [1299682836.038946398]: [/openni_node1] searching for device with index = 1
[openni_node1-2] process has died [pid 3221, exit code -4].
log files: /home/user/.ros/log/fc4411f6-4a5d-11e0-bde6-001d7e94a572/openni_node1-2*.log

The log is saying:

[roscpp_internal] [2011-03-09 16:00:35,930] [thread 0xb696a740]: [DEBUG] UDPROS server listening on port [55561]
[roscpp_internal] [2011-03-09 16:00:35,940] [thread 0xb696a740]: [DEBUG] Started node [/openni_node1], pid [3221], bound on [user-desktop], xmlrpc port [50421], tcpros port [47638], logging to [/home/user/.ros/log/fc4411f6-4a5d-11e0-bde6-001d7e94a572/openni_node1-2.log], using [real] time
[roscpp_internal] [2011-03-09 16:00:35,961] [thread 0xb696a740]: [DEBUG] XML-RPC call [getParam] returned an error (-1): [Parameter [/openni_node1/num_worker_threads] is not set]
[ros.openni_camera./openni_node1] [2011-03-09 16:00:36,033] [thread 0xb696a740]: [INFO] [/openni_node1] Number devices connected: 1
[ros.openni_camera./openni_node1] [2011-03-09 16:00:36,034] [thread 0xb696a740]: [INFO] [/openni_node1] 1. device on bus 001:31 is a Xbox NUI Camera (2ae) from Microsoft (45e) with serial id 'A00364814366047A'
[ros.openni_camera./openni_node1] [2011-03-09 16:00:36,038] [thread 0xb696a740]: [INFO] [/openni_node1] searching for device with index = 1
[roscpp_internal] [2011-03-09 16:00:36,160] [thread 0xb6969b70]: [DEBUG] Accepted connection on socket [7], new socket [16]
[roscpp_internal] [2011-03-09 16:00:36,160] [thread 0xb6969b70]: [DEBUG] TCPROS received a connection from [192.168.5.101:46329]
[roscpp_internal] [2011-03-09 16:00:36,160] [thread 0xb6969b70]: [DEBUG] Connection: Creating TransportSubscriberLink for topic [/rosout] connected to [callerid=[/rosout] address=[TCPROS connection to [192.168.5.101:46329 on socket 16]]]

My udev rules are set as said in Wiki:

ATTRS{idProduct}=="0200",ATTRS{idVendor}=="1d27",MODE="666",GROUP="video"
ATTRS{idProduct}=="0300",ATTRS{idVendor}=="1d27",MODE="666",GROUP="video"
ATTRS{idProduct}=="0400",ATTRS{idVendor}=="1d27",MODE="666",GROUP="video"
ATTRS{idProduct}=="0500",ATTRS{idVendor}=="1d27",MODE="666",GROUP="video"
ATTRS{idProduct}=="0600",ATTRS{idVendor}=="1d27",MODE="666",GROUP="video"
ATTRS{idProduct}=="02ae",ATTRS{idVendor}=="045e",MODE="666",GROUP="video"
ATTRS{idProduct}=="02ad",ATTRS{idVendor}=="045e",MODE="666",GROUP="video"
ATTRS{idProduct}=="02b0",ATTRS{idVendor}=="045e",MODE="666",GROUP="video"

Any clues ... (more)

edit retag flag offensive close merge delete

Comments

What platform are you running on? OS, hardware, etc?
tfoote gravatar imagetfoote ( 2011-03-11 07:00:44 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
1

answered 2011-03-14 22:22:22 -0500

tom gravatar image

The problem was my machine doesn't have SSE3 support. The solution to the problem can be found here.

edit flag offensive delete link more
0

answered 2011-03-11 05:57:31 -0500

I have no idea, but I would try to run the driver in a debugger. Just edit the launch file as described here

Basic commands in gdb:

run - start the program
bt - see the stacktrace
up - go up a level in the stacktrace
list - view source code at current stack level
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-03-09 01:54:23 -0500

Seen: 818 times

Last updated: Mar 14 '11