ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

WARNING: ROS_MASTER_URI [] host is not set to this machine

asked 2012-11-21 14:52:55 -0500

longzhixi123 gravatar image

updated 2018-07-12 21:43:33 -0500

jayess gravatar image

hello,i am trying to use turtlebot as website link text. when i have done link text. and i can check that TurtleBot laptop can get data from ROS node running on workstation. and the problem is when i run "roscore"in my workstation , i get

waring:WARNING: ROS_MASTER_URI [] host is not set to this machine.

and is my turtlebot ip.and my workstation ip is when i run

$ rosrun turtlebot_dashboard turtlebot_dashboard&

my dashboard buttons remain all grey. what's matter ?thank s a lot

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted

answered 2012-11-21 22:01:09 -0500

Ben_S gravatar image

You can only have one roscore active (and configured) at a time. In case of the turtlebot the roscore should always run on the turtlebot itself to keep latencies and actual network usage low.

If you wanted to use a roscore on your workstation to work, while the turtlebot isn't running, you have to change your ROS_MASTER_URI to the name or IP of your workstation.

Dont forget to source the .bashrc again after the change, or restart your open consoles.

edit flag offensive delete link more

answered 2012-11-21 15:30:12 -0500

Atom gravatar image

updated 2012-11-21 21:50:29 -0500

Seems to me that you may have not properly set up your ROS network. I wrote a tutorial that might help you

But I would also look more closely at the ROS Wiki and double check your settings. If you check your bashrc with gedit "gedit ~/.bashrc" what do your ROS settings look like?

edit flag offensive delete link more

Question Tools

1 follower


Asked: 2012-11-21 14:52:55 -0500

Seen: 25,247 times

Last updated: Jul 12 '18