Ask Your Question
0

cannot run rviz for TurtleBot [closed]

asked 2013-03-03 20:24:37 -0600

Chik gravatar image

updated 2013-03-04 12:01:13 -0600

bit-pirate gravatar image

When I run

rosrun rviz rviz

I received the following

rviz revision number 1.6.7
ogre_tools revision number 1.6.3 
compiled against OGRE version 1.7.3 (Cthugha)
Loading general config from [/home/turtle/.rviz/config]
Loading display config from [/home/turtle/.rviz/display_config]
RTT Preferred Mode is PBuffer.
Texture for pass 0: creating with size 1 x 1 
Segmentation fault

Please help me if anyone knows what is wrong. Thank you very much.

Background: Clearpath TurtleBot with Kinect and iRobot Create; Ubuntu 10.04.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Chik
close date 2013-03-10 15:14:16

Comments

1

Are you using a laptop with nvidia graphics card ? If so, try installing bumblebee and run optirun rosrun rviz rviz.

prasanna.kumar gravatar imageprasanna.kumar ( 2013-03-03 20:27:41 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2013-03-04 12:56:48 -0600

Chik gravatar image

updated 2013-03-04 12:57:18 -0600

I re-installed the nvidia driver and it works now.

sudo apt-get install nvidia-current

then

sudo -i

sudo nvidia-xconfig

then restart the computer.

edit flag offensive delete link more

Question Tools

Stats

Asked: 2013-03-03 20:24:37 -0600

Seen: 125 times

Last updated: Mar 04 '13