ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

no image received in rviz (turtlebot sim)

asked 2014-11-13 06:16:22 -0600

turtlebot_lille gravatar image

updated 2015-10-26 18:51:48 -0600

tfoote gravatar image

Hi everyone,

I have just started with Ubuntu, ROS and Gazebo so I really do not know much yet. However, I really want to learn as much as possible and as fast as possible so please help me.

I am going through the tutorials for the turtlebot simulation on Gazebo after going through the tutorial from gazebosim. I can make the robot move with the command but I am having issues with the RViz parts. In the first tutorial, when I open RVIZ, to visualize my world in Gazebo, I have a warning for the image. It displays no image received. I can still see the obstacles added to the world with the point cloud. Do you know why I am not receiving any image?

USing Hydro and gazebo 1.9


edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted

answered 2020-04-02 14:36:24 -0600

Shivendra gravatar image

This is specific to Turtlebot3. The 'burger' model doesn't have a camera whereas the 'waffle_pi' does. I had to reset the model to waffle_pi to get all the camera related topics.

edit flag offensive delete link more


Thank you for this! I wish this information was included in beginner tutorials on Turtlebot3.

trunc8 gravatar image trunc8  ( 2020-07-03 09:52:25 -0600 )edit

answered 2015-10-27 01:20:03 -0600

nampi gravatar image

tfoote, thanks for your answer. I had the same problem and used your advice.

  1. Firstly, I'd like to add more detailed answer.

    Edit the parameter "Image"->"Image Topic" to possible value (for example, "/camera/rgb/image_raw"). You can find possible values click on the drop-down list on the "Image"->"Image Topic". It works only for this session.

    If you want to make changes to all sessions, edit this parameter in the config: robot.rviz. You can find the path in File->Open Config. In robot.rviz find "Class: rviz/Image" and edit "Image Topic".

  2. Secondly, I'd like to add other decision. You can use current Topic (at least "/camera/rgb/image_rect_color"). Install "openni" and launch it:

    1. sudo apt-get install ros-indigo-openni-launch
    2. In a new terminal execute: roslaunch openni_launch openni.launch load_driver:=false depth_registration:=true
edit flag offensive delete link more


@nampi Thanks for digging in. Could you look at submitting it upstream to the turtlebot_interactions repo. There might be some discussion about how to make it work for both simulation and the real robot but we should make it compatible for both.

tfoote gravatar image tfoote  ( 2015-10-27 02:26:02 -0600 )edit

answered 2015-10-26 18:51:38 -0600

tfoote gravatar image

It might be that the rviz config is connected to the wrong topic. See if there's another topic available to select for the image.

edit flag offensive delete link more

Question Tools



Asked: 2014-11-13 06:16:22 -0600

Seen: 4,577 times

Last updated: Oct 27 '15