Ask Your Question
0

Kinect "no device connected" error in openni.launch after openni-dev package upgrade

asked 2014-03-12 01:02:54 -0500

Brijendra Singh gravatar image

updated 2016-10-24 08:36:36 -0500

ngrennan gravatar image

Hi,

I'm using turtlebot on ROS electric on ubuntu 11.04.

The openni-dev package was recently updated from version 1.1.0.41~natty to 1.3.2.1-4~natty2. After this update, the openni.launch process gives the error "No device connected.. Waiting for devices to be connected". Its not able to initialize.

I tried to downgrade the openni-dev version using the command: "sudo apt-get install openni-dev=1.1.0.41~natty", but it says that the version was not found. I have also tried replacing the entries in the source.list files for apt to "old-releases.ubuntu.com", but it still didn't work.

Any help would be appreciated.

Thanks.

edit retag flag offensive close merge delete

Comments

You should be aware that ROS electric is quite old and a lot of the packages deprecated

Athoesen gravatar image Athoesen  ( 2014-05-14 12:14:56 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2014-03-23 20:36:22 -0500

Brijendra Singh gravatar image

I resolved the issue by un-installing the openni-dev package, which also removed the dependencies - nite-dev, ps-engine, ros-electric-turtlebot, ros-electric-turtlebot-desktop, ros-electric-turtlebot-robot, ros-electric-turtlebot-viz, ros-electric-openni-kinect. And then re-installing these packages.

The openni.launch process is working fine now.

edit flag offensive delete link more

Comments

Can you tell me how you solve it in detals?please.

xianke gravatar image xianke  ( 2016-03-26 00:32:06 -0500 )edit
0

answered 2014-03-12 01:15:14 -0500

Winston gravatar image

I have simialr questions as well. I dont know either.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-03-12 01:02:54 -0500

Seen: 308 times

Last updated: Mar 23 '14