Ask Your Question
0

How to install ROS fuerte on ubuntu 11.10 64 bits?

asked 2012-11-15 18:16:38 -0500

sam gravatar image

updated 2012-11-15 21:25:17 -0500

Lorenz gravatar image

When I apt-get it shows:

sam@robot:~$ sudo apt-get install ros-fuerte-desktop-full
[sudo] password for sam: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 ros-fuerte-desktop-full : Depends: ros-fuerte-nodelet-core (= 1.6.5-s1347168835~precise) but it is not going to be installed
                           Depends: ros-fuerte-geometry-tutorials (= 0.1.3-s1348603799~precise) but it is not going to be installed
                           Depends: ros-fuerte-orocos-kinematics-dynamics (= 0.2.3-s1347124102~precise) but it is not going to be installed
                           Depends: ros-fuerte-filters (= 1.6.0-s1347133504~precise) but it is not going to be installed
                           Depends: ros-fuerte-slam-gmapping (= 1.2.7-s1350948390~precise) but it is not going to be installed
                           Depends: ros-fuerte-simulator-gazebo (= 1.6.16-s1347172830~precise) but it is not going to be installed
                           Depends: ros-fuerte-visualization (= 1.8.14-s1350944568~precise) but it is not going to be installed
                           Depends: ros-fuerte-vision-opencv (= 1.8.8-s1349900876~precise) but it is not going to be installed
                           Depends: ros-fuerte-perception-pcl (= 1.2.3-s1347170256~precise) but it is not going to be installed
                           Depends: ros-fuerte-geometry-experimental (= 0.2.3-s1347133731~precise) but it is not going to be installed
                           Depends: ros-fuerte-robot-model-visualization (= 0.1.2-s1347128386~precise) but it is not going to be installed
                           Depends: ros-fuerte-common-tutorials (= 0.2.3-s1348603925~precise) but it is not going to be installed
                           Depends: ros-fuerte-image-pipeline (= 1.8.5-s1349902794~precise) but it is not going to be installed
                           Depends: ros-fuerte-bfl (= 0.1.0-s1347124244~precise) but it is not going to be installed
                           Depends: ros-fuerte-diagnostics-monitors (= 1.4.3-s1347133511~precise) but it is not going to be installed
                           Depends: ros-fuerte-common-rosdeps (= 1.2.0-s1347122840~precise) but it is not going to be installed
                           Depends: ros-fuerte-geometry-visualization (= 0.1.1-s1347141454~precise) but it is not going to be installed
                           Depends: ros-fuerte-image-common (= 1.8.0-s1347133482~precise) but it is not going to be installed
                           Depends: ros-fuerte-bond-core (= 1.6.3-s1347128144~precise) but it is not going to be installed
                           Depends: ros-fuerte-python-qt-binding (= 0.1.9-s1348595482~precise) but it is not going to be installed
                           Depends: ros-fuerte-visualization-common (= 1.8.4-s1347128602~precise) but it is not going to be installed
                           Depends: ros-fuerte-physics-ode (= 1.8.0-s1347122907~precise) but it is not going to be installed
                           Depends: ros-fuerte-driver-common (= 1.4.0-s1347168681~precise) but it is not going to be installed
                           Depends: ros-fuerte-executive-smach (= 1.2.0-s1347133680~precise) but it is not going to be installed
                           Depends: ros-fuerte-stage (= 1.6.6-s1347133988~precise) but it is not going to be installed
                           Depends: ros-fuerte-dynamic-reconfigure (= 1.4.2-s1347168414~precise) but it is not going to be installed
                           Depends: ros-fuerte-image-transport-plugins (= 1.8.2-s1349902769~precise) but it is not going to be installed
                           Depends: ros-fuerte-xacro (= 1.6.1-s1347128571~precise) but it is not going to be installed
                           Depends: ros-fuerte-robot-model (= 1.8.1-s1347133837~precise) but it is not going to be installed
                           Depends: ros-fuerte-bullet (= 2.79-s1347124289~precise) but it is not going to be installed ...
(more)
edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
0

answered 2012-11-15 21:28:20 -0500

Lorenz gravatar image

You are trying to install Precise packages (Ubuntu 12.04) instead of Oneiric packages. Fix /etc/apt/sources.list.d/ros-latest.list (rename precise by oneiric) and don't forget to sudo apt-get update before you try to install again.

edit flag offensive delete link more
0

answered 2012-11-15 21:25:27 -0500

dornhege gravatar image

The errors look like you have ROS precise in your sources.list instead of oneiric. You should fix that and redo apt-get update.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-11-15 18:16:38 -0500

Seen: 398 times

Last updated: Nov 15 '12