ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

SolidWorks->urdf exporter strange behavior when click "Preview and Export..."

asked 2012-10-25 03:35:02 -0500

Peter Galambos gravatar image

I have tried to export a milling machine from a SolidWorks assembly to urdf using the exporter plug-in developed by Stephen Brawner. There were no problem when completing the form "Configure and Organize Links" but in the next step when I clicked the button "Preview and Export..." the exporter just stopped without any error message.

The assembly can be downloaded from [here](

Does anyone know about this problem?

edit retag flag offensive close merge delete

5 Answers

Sort by ยป oldest newest most voted

answered 2012-12-14 09:50:43 -0500

brawner gravatar image

updated 2013-02-13 13:15:54 -0500

Many bugs have been addressed through newer updates of the software. Download the latest version and see if there your problem still exists. If so, please report it to the issue tracker:

edit flag offensive delete link more


Unfortunately the same problem happened to me even with the newest version (as of August 2017). It's already been raised as an issue (see the link) on Bitbucket so I'm not adding a new one.

AdamSorrel gravatar image AdamSorrel  ( 2017-08-21 16:08:43 -0500 )edit

answered 2017-08-21 16:07:25 -0500

AdamSorrel gravatar image

Despite being an old thread, this issue seems to be reappearing. I've spent quite a lot of time researching an answer, so I would like to leave a solution/workaround here. It should be noted that it's heavily based on Ari Kapusta's comment in the SW2URDF repository on Bitbucket.

In essence it seems that the automatic generation of joints fails without giving any warning or error. Luckily you can define the joints yourself and effectively skip this part of the process. You can refer to the original issue with a solution here or for more detailed information check my blog post where I've described the whole process in detail.

Hope this saves you the time and troubles.

edit flag offensive delete link more


In your blog post your wrote Check which joint origins and axis have been generated and whether some of them seem correct. How can I check it?

markovalexey gravatar image markovalexey  ( 2018-03-04 07:18:47 -0500 )edit

After you have generated the joint origins, they will appear in the left widget where you have all the other objects. Sometimes they are generated in a wrong position, like the base of your robot or somewhere you don't want them. So you will need to move them to the right position in solidworks.

AdamSorrel gravatar image AdamSorrel  ( 2018-03-08 05:48:00 -0500 )edit

If you need more detailed description, leave me a message on the blog and I'll put up some pictures there as well.

AdamSorrel gravatar image AdamSorrel  ( 2018-03-08 05:50:05 -0500 )edit

answered 2019-04-12 09:54:19 -0500

i had the same problem and i solved it. So why the exporter just stopped ? this is because the exporter can not create for example the axis of a revolute joint when you leave the option "automatically generate". In my case, i had defined fully 3 mates for the realated object, so the exporter could not find the degree of freedom to assume that the part can revolve( be free) around an axis. Hope this helps

edit flag offensive delete link more

answered 2014-02-06 07:59:06 -0500

Max Crittenden gravatar image

Stephen, I'm having a similar problem with my own assembly. The exporter establishes a few origins and axes, and then just quits working. I've noticed that at the same time it fixes parts in Solidworks that weren't fixed before, which naturally produces mate errors. I've tried paring back my assembly, suppressing parts, and if I go back far enough the export works. Any idea what I can try next?

edit flag offensive delete link more

answered 2013-01-18 05:43:13 -0500

Felix Messmer gravatar image


I have the same problems with my CAD data for the Yaskawa Motoman SDA 10D.

I am using the latest version of the SW2URDF-Exporter (downloaded today).

I found that similar as in Peter Galambos' MillingMachine, the parts of the SDA 10D are marked fixed and no Mates are defined. Does this cause the problem?

Is there a solution to this issue? Thanks!

edit flag offensive delete link more


Yes, having all your links as fixed parts without any explicit degrees of freedom will not allow the exporter to infer the type of joint. The fact that it stops abruptly without warning may be a bug. I received your email, and i'll respond to it.

brawner gravatar image brawner  ( 2013-01-18 06:27:31 -0500 )edit

Question Tools



Asked: 2012-10-25 03:35:02 -0500

Seen: 2,895 times

Last updated: Feb 06 '14