Ask Your Question
0

SolidWorks URDF exporter incorrect link masses

asked 2012-10-31 17:34:36 -0500

rdeits gravatar image

As far as I can tell, there seems to be an issue with the SW->URDF converter which causes the mass of every link to be set to the mass of the entire assembly, rather than that single link. For example, I can create a robot composed of two rectangular links, one of length 1m and expected mass 10kg and one of length 0.5m and expected mass 5kg. When the exporter runs, it assigns a mass of 15kg to both links. Am I misinterpreting the expected behavior?

I've also noticed that looking carefully at the video on the Willow Garage blog here: http://www.willowgarage.com/blog/2012/10/18/exporting-urdfs-directly-solidworks (at around 59s) that the demo appears to have the same behavior I observed.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2012-12-14 09:48:34 -0500

brawner gravatar image

updated 2012-12-14 12:28:02 -0500

Yes, sorry for the delay in answering this question. This was addressed in version V1.0 Build 4714.35040 (released much later than the posting of this question).

For future reference, issues with this tool should be reported on the issue tracker for this project.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

4 followers

Stats

Asked: 2012-10-31 17:34:36 -0500

Seen: 263 times

Last updated: Dec 14 '12