Ask Your Question
2

How do I prevent segmentation fault when starting rviz?

asked 2012-10-18 09:27:38 -0600

sinha.karsh gravatar image

updated 2014-01-28 17:13:59 -0600

ngrennan gravatar image

I am currently using ROS Fuerte on Ubuntu 12.04LTS. I know there have been several forum topics mentioning the same problem I had but none of them seem to offer me the right solution, so here I am asking the question again. After having created a workspace in ROS and sourcing the setup.bash file, I run 'rosdep install rviz'. Once all the dependencies have been installed, I compile the package using 'rosmake rviz'. The package builds successfully. I then run 'rosrun rviz rviz' and get the following results (ignore the color coding):


sinhau@ubuntu:~/tf_tutorials$ rosrun rviz rviz

[ INFO] [1350587343.349569680]: rviz revision number 1.8.14

[ INFO] [1350587343.349747565]: compiles against OGRE version 1.7.3 (Cthugha)

[ INFO] [1350587343.378668970]: Loading general config from [/home/sinhau/.rviz/config]

Config file '/home/sinhau/.rviz/config' could not be opened for reading.

Segmentation fault (core dumped)

I looked into the '.rviz' folder and found it to be empty. So I have no idea what the problem is. Some of the suggested solutions in other forums were to change the variable OGRE_RTT_MODE to either Copy,FBO, or PBuffer. I tried all of them using export OGRE_RTT_MODE=________ and reran rviz using 'rosrun rviz rviz'. The results were still the same. If anybody has an idea as to what's going on, sharing it would be much appreciated.

Thanks!

edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted
1

answered 2013-02-19 21:57:53 -0600

dbworth gravatar image

It will be the graphics card. If you're lucky you need to install the proprietory ATI or NVidia drivers. The best choice is to use a computer with an NVidia gaming 3D graphics card, you will have less problems :-)

edit flag offensive delete link more
0

answered 2013-02-19 12:05:39 -0600

sinha.karsh gravatar image

Sorry for the late reply. I actually moved to a different computer and rviz is working correctly on this one. Not quite sure what the issue was on previous computer but it works now!

edit flag offensive delete link more

Comments

May I ask why you were compiling rviz? Unless you're modifying source coude, it's usually much easier to download the packages using apt-get in Ubuntu.

georgebrindeiro gravatar imagegeorgebrindeiro ( 2013-02-19 12:24:14 -0600 )edit

I was just trying to run rviz to see if it worked or not.

sinha.karsh gravatar imagesinha.karsh ( 2013-02-19 12:33:13 -0600 )edit
0

answered 2012-11-02 11:27:09 -0600

Walter CHU gravatar image

Hi sinha.karsh Have you solved the problem? Something similar happened to me, and the problem might be about your graphics card's driver. If you using ATI card, here is some guidance: [SOLVED] Installing Catalyst 12-4 on Precise 32-bit (Patch) I already done is and it looks good. Good luck!

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-10-18 09:27:38 -0600

Seen: 2,092 times

Last updated: Feb 19 '13