Ask Your Question
0

Upgrading to Fuerte and Ubuntu 12.04 Woes

asked 2012-08-23 11:24:21 -0500

jker gravatar image

updated 2014-01-28 17:13:26 -0500

ngrennan gravatar image

I recently decided to upgrade my project created on Electric on Ubuntu 10.04 to Fuerte and 12.04 for various reasons. Everything worked fine with the old setup, and many things would be broken in the upgrade. I managed to fix most of them, however there are several which I just cannot figure out and have been unable to find clear explanations about online. I've tried to make the descriptions brief so this post doesn't become monstrous, but please ask questions if you have them and I'll try to stay on top of this post. Also, I can't get the hang of formatting for these posts, so I put the lines as numbered lists, the numbers don't actually mean anything.

Thanks!


Problem A) It looks like it can't find liblog4c.so file, or that I need to manually add it. However any attempt to do so in the CMakeLists.txt file for the package just turns up more errors.

  1. [ 80%] Building CXX object src/utils/CMakeFiles/getFirmwareVersion.dir/getFirmwareVersion.o
  2. Linking CXX executable ../../../bin/getFirmwareVersion
  3. /usr/bin/ld: CMakeFiles/getFirmwareVersion.dir/getFirmwareVersion.o: undefined reference to symbol 'typeinfo for log4cxx::helpers::ObjectPtrBase'
  4. /usr/bin/ld: note: 'typeinfo for log4cxx::helpers::ObjectPtrBase' is defined in DSO /usr/lib/liblog4cxx.so.10 so try adding it to the linker command line
  5. /usr/lib/liblog4cxx.so.10: could not read symbols: Invalid operation
  6. collect2: ld returned 1 exit status <h2&gt;<br/></h2&gt;<>

Problem B) I'm very confused as to why the uvc_camera package suddenly needs a .cfg file, as it wasn't an issue before.

  1. CMake Error at /opt/ros/fuerte/stacks/dynamic_reconfigure/cmake/cfgbuild.cmake:82 (message):
    Dynamic reconfigure has been invoked but could not find a .cfg to build.
    Please add one to your package/cfg directory. Aborting.
  2. Call Stack (most recent call first):
    /opt/ros/fuerte/stacks/dynamic_reconfigure/cmake/cfgbuild.cmake:87 (gencfg_cpp)
    CMakeLists.txt:25 (include) <h2&gt;<br/></h2&gt;<>

Problem C) There are many more errors similar to the ones below that I left out to make this post shorter. From what it looks like, tf got a few major changes, do I just have to go through manually and change everything to the new tf functions and objects?

  1. /myRos/laser_pipeline/laser_geometry/src/laser_geometry.cpp: In member function 'void laser_geometry::LaserProjection::transformLaserScanToPointCloud_(const string&, sensor_msgs::PointCloud&, const LaserScan&, tf::Transformer&, double, int)':
  2. /myRos/laser_pipeline/laser_geometry/src/laser_geometry.cpp:251:86: error: no matching function for call to 'btVector3::setInterpolate3(tf::Vector3&, tf::Vector3&, btScalar&)'
  3. /myRos/laser_pipeline/laser_geometry/src/laser_geometry.cpp:251:86: note: candidate is:
  4. /opt/ros/fuerte/stacks/bullet/include/LinearMath/btVector3.h:236:25: note: void btVector3::setInterpolate3(const btVector3&, const btVector3&, btScalar)
  5. /opt/ros/fuerte/stacks/bullet/include/LinearMath/btVector3.h:236:25: note: no known conversion for argument 1 from 'tf::Vector3' to 'const btVector3&'
  6. /myRos/laser_pipeline/laser_geometry/src/laser_geometry.cpp:256:48: error: no matching function for call to 'tf::Matrix3x3::getRotation ...
(more)
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
2

answered 2012-08-23 23:28:32 -0500

AHornung gravatar image

I think that most (if not even all) of your problems can be fixed with the following instructions: http://ros.org/wiki/fuerte/Migration

Especially see 1.1 and 1.7

edit flag offensive delete link more

Comments

Thanks, that helped solve all but issue B. However I was able to find the answer to that at http://answers.ros.org/question/39031/error-in-compiling-uvc_cam/

jker gravatar imagejker ( 2012-08-24 04:20:40 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-08-23 11:24:21 -0500

Seen: 1,270 times

Last updated: Aug 23 '12