Ask Your Question
1

cannot run roscore due to error in rosversion

asked 2012-10-02 10:01:39 -0600

bhaskara gravatar image

updated 2012-12-09 02:11:37 -0600

Kevin gravatar image

When running roscore with a new groovy install, i get this error:

... logging to /u/bhaskara/.ros/log/2674d9d4-0ccb-11e2-9426-f46d0429e87d/roslaunch-spf-11815.log
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
WARNING: disk usage in log directory [/u/bhaskara/.ros/log] is over 1GB.
It's recommended that you use the 'rosclean' command.
WARNING: disk usage in log directory [/u/bhaskara/.ros/log] is over 1GB.
It's recommended that you use the 'rosclean' command.
2;roscore
Cannot locate [ros]Invalid <param> tag: Cannot load command parameter [rosversion]: command [rosversion ros] returned with code [1]. 

Param xml is <param command="rosversion ros" name="rosversion"/>
Invalid <param> tag: Cannot load command parameter [rosversion]: command [rosversion ros] returned with code [1]. 

Param xml is <param command="rosversion ros" name="rosversion"/>
edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted
5

answered 2012-10-10 07:39:43 -0600

hersh gravatar image

This is caused by having a previously-installed "pip" version of rospkg which is out of date.

Fix this by:

sudo pip uninstall rospkg

repeat this until it says "not found"

then to be sure you have the latest:

sudo apt-get update sudo apt-get install python-rospkg

The "pip uninstall" version is supposed to work, but personally I did:

sudo rm -rf /usr/local/lib/python2.7/dist-packages/catkin* sudo rm -rf /usr/local/lib/python2.7/dist-packages/ros* sudo rm -rf /usr/local/bin/ros* sudo rm -rf /usr/local/bin/catkin*

to remove the old pip-installed versions. This should be safe for both Fuerte and Groovy users, because these tools are all now installed to /usr/ instead of /usr/local and are available as debian packages.

edit flag offensive delete link more

Comments

Thanks this really helped me out.

Nigel gravatar imageNigel ( 2013-08-04 03:34:46 -0600 )edit

Worked for me as well for Indigo, I had an old Fuerte installed. But I didn't had to do the last steps with sudo rm.

Cyril_J gravatar imageCyril_J ( 2014-12-18 04:19:09 -0600 )edit
2

answered 2012-10-04 02:33:04 -0600

felix k gravatar image

"Actually, rospkg should not be installed using easy_install or pip anymore."

How have you installed rosdep/rospkg?

See my answer on that possible duplicate question and the link in Lorenz' comment: problem-to-start-roscore-on-arm-ubuntu-1204/?answer=42334

edit flag offensive delete link more
0

answered 2012-10-02 11:32:50 -0600

joq gravatar image

That works for me. Looks like rosversion can't find ros.

What is your ROS environment set to?

env | fgrep ROS
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-10-02 10:01:39 -0600

Seen: 5,155 times

Last updated: Dec 06 '12