Ask Your Question
0

Problem to start roscore on ARM + Ubuntu 12.04

asked 2012-08-26 11:17:42 -0500

dinamex gravatar image

updated 2014-01-28 17:13:28 -0500

ngrennan gravatar image

Hi there,

I installed ros fuerte from source on a new installation of Ubuntu 12.04. When I want to run roscore i get following failure message:

 ... logging to /home/panda/.ros/log/4b069fea-efbf-11e1-b011-2e607c264e01/roslaunch-panda-1813.log
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

Traceback (most recent call last):
  File "/opt/ros/fuerte/bin/rosversion", line 5, in <module>
    pkg_resources.run_script('rospkg==1.0.6', 'rosversion')
  File "/usr/lib/python2.7/dist-packages/pkg_resources.py", line 499, in run_script
    self.require(requires)[0].run_script(script_name, ns)
  File "/usr/lib/python2.7/dist-packages/pkg_resources.py", line 1229, in run_script
    raise ResolutionError("No script named %r" % script_name)
pkg_resources.ResolutionError: No script named 'rosversion'
Invalid <param> tag: Cannot load command parameter [rosversion]: command [rosversion ros] returned with code [1].

Param xml is <param command="rosversion ros" name="rosversion"/>

I saw that there was already a question regarding to this kind of failure. So I deleted all rospkg regarding folders under /usr/local/lib/python2.7/dist-packages/ and used

 $sudo easy_install -U rospkg

Unfortunately, I got a different failure msgs then:

 ... logging to /home/panda/.ros/log/e6c9fbac-efbf-11e1-8192-2e607c264e01/roslaunch-panda-1830.log
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

Unable to contact my own server at [http://panda:60413/].
This usually means that the network is not configured properly.

A common cause is that the machine cannot ping itself.  Please check
for errors by running:

        ping panda

For more tips, please see

        http://www.ros.org/wiki/ROS/NetworkSetup

Which is really weird because i can ping myself without a problem. I deleted all rospkg folders again and used to get back to the old setup.

$sudo pip install -U rospkg

there was a interesting output while installing

Installing collected packages: rospkg
  Running setup.py install for rospkg
    changing mode of build/scripts-2.7/rosversion from 644 to 755

So a ROS-Version must be set somewhere.

the output from $roswtf ist

No package or stack in context
================================================================================
Static checks summary:

Found 1 error(s).

ERROR Not all paths in ROS_PACKAGE_PATH [/opt/ros/fuerte/share:/opt/ros/fuerte/stacks] point to an existing directory:
 * /opt/ros/fuerte/stacks

================================================================================

ROS Master does not appear to be running.
Online graph checks will not be run.
ROS_MASTER_URI is [http://localhost:11311]

I appreciate any kind of suggestions.


Edit:

Lorenz answer is the solution to the problem. I used $ sudo easy_install rospkg and then added

export ROS_HOSTNAME=localhost  
export ROS_MASTER_URI=http://localhost:11311

to my .bashrc

There is now a failure msgs about

Exception AttributeError: AttributeError("'_DummyThread' object has no attribute '_Thread__block'",) in <module 'threading' from '/usr/lib/python2.7/threading.pyc'> ignored

but this shouldn't be an issue. (reference)

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
2

answered 2012-08-27 04:43:06 -0500

Lorenz gravatar image

I guess you have two problems:

  1. rosversion could not be found which you apparently fixed by using easy_install and
  2. a network problem that might be solved by setting ROS_IP. A quick search shows this. This and this are probably the answers you are looking for.
edit flag offensive delete link more

Comments

Do you know why my system needs to set to localhost? shouldn't it be panda... at least my command line says panda@panda

dinamex gravatar imagedinamex ( 2012-08-27 05:30:42 -0500 )edit

Did you try to explicitly set ROS_HOSTNAME to panda?

Lorenz gravatar imageLorenz ( 2012-08-27 05:34:07 -0500 )edit

when i try panda it says "Unable to contact my own server at [http://panda:60413/]" its just working with localhost. panda seems to be the default ROS_HOSTNAME as well.

dinamex gravatar imagedinamex ( 2012-08-27 05:39:02 -0500 )edit

And you can ping panda? Did you set it in /etc/hosts? Did you have a look at this page and went through all steps?

Lorenz gravatar imageLorenz ( 2012-08-27 05:43:50 -0500 )edit

I was able to ping panda but I needed to add "127.0.1.1 panda" to my /etc/hosts to get roscore to work

dinamex gravatar imagedinamex ( 2012-08-27 10:04:36 -0500 )edit
1

answered 2012-08-26 22:05:03 -0500

felix k gravatar image

"Actually, rospkg should not be installed using easy_install or pip anymore."

Probably this is a duplicate of cannot-run-roscore-with-latest-ubuntu-1204-packages which also is a duplicate of update-fuerte-to-1810-breaks-rospkg.

edit flag offensive delete link more

Comments

this is not the same failure... the questions your are refering to have problems with some author tags. For me is that the script is missing or better the script name is not defined

dinamex gravatar imagedinamex ( 2012-08-27 02:05:32 -0500 )edit

I actually think although you are seeing a different error, it might still be related to your pip/easy_install based installation of rospkg. Do not install it using pip/easy_install but with sudo apt-get install python-rospkg. You need to manually delete all files installed using pip now.

Lorenz gravatar imageLorenz ( 2012-08-27 02:47:12 -0500 )edit
1
Lorenz gravatar imageLorenz ( 2012-08-27 02:49:23 -0500 )edit

I'm using an ARM processor and there is no deb-pkg to install with apt-get. How can I install it from source? I can't find the source code or a how-to to install it alternatively! I used the installation guide for fuerte from source and even there is rospkg installed with pip...

dinamex gravatar imagedinamex ( 2012-08-27 03:36:35 -0500 )edit

Ok. Then never mind. In that case pip is the right way to install rospkg. But next time, please mention that you are using ARM when asking a question.

Lorenz gravatar imageLorenz ( 2012-08-27 03:38:27 -0500 )edit

Sorry that I forgot to mention this. the pip installation is not working as I wrote in my question. Any other ideas?

dinamex gravatar imagedinamex ( 2012-08-27 04:36:03 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-08-26 11:17:42 -0500

Seen: 2,353 times

Last updated: Aug 27 '12