Ask Your Question
0

output update of ROBOT_POSE_EKF is 5 sec. Can I get them faster?

asked 2012-09-23 17:09:04 -0600

sai gravatar image

updated 2012-09-24 00:04:24 -0600

Question 1.. Can I just use wheel odometry data and imu data and get effective kalman updated data using robot_pose_ekf package?Is there any package which is more handy which I overlooked?

Question 2.. The output of /robot_pose_ekf/odom_combined is same as the /pose published by wheel odometry. Do I have to make any changes?

Question3..Message update rate is around 5 sec and can I decrease it ?

I tried changing the freq parameter in robot_pose_ekf.launch from 30 hz to 120 hz but the update comes around once in 5 sec.

Sometimes the output does not start immediately.

nutan@nutan-laptop:~$ rostopic hz /robot_pose_ekf/odom_combined

subscribed to [/robot_pose_ekf/odom_combined]

average rate: 0.018

min: 55.560s max: 55.560s std dev: 0.00000s window: 2

no new messages

no new messages

no new messages

no new messages

average rate: 0.033

min: 5.054s max: 55.560s std dev: 25.25297s window: 3

no new messages

no new messages

no new messages

no new messages

average rate: 0.046

min: 5.053s max: 55.560s std dev: 23.80890s window: 4

no new messages

no new messages

no new messages

no new messages

average rate: 0.057

min: 5.053s max: 55.560s std dev: 21.86982s window: 5

no new messages

no new messages

no new messages

no new messages

average rate: 0.066

min: 5.053s max: 55.560s std dev: 20.20241s window: 6

no new messages

no new messages

no new messages

no new messages

no new messages

no new messages

no new messages

no new messages

no new messages

no new messages

no new messages


edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
2

answered 2012-10-01 18:07:50 -0600

sai gravatar image

Finally after three days, found the answer...

First the error was

"Could not transform the imu messages from /base_imu to /base_footprint"

This was found from the rxconsole output.

TF tree was connected.

It was solved by changing the (/base_imu)frame id of IMU to /base_footprint

Thats it...:)

edit flag offensive delete link more

Comments

Glad you solved the problem. Would you mind marking the answer as accepted?

jarvisschultz gravatar imagejarvisschultz ( 2012-10-01 18:19:49 -0600 )edit

did that

sai gravatar imagesai ( 2012-10-03 00:36:32 -0600 )edit

This helped me figure out why EKF's update rate was incorrect. Just like in your case, the EKF node was complaining about the IMU messages not having base_footprint IDs. After specifying "base_footprint" for the "frame_id" param for the IMU node, the EKF node's rate increased to 5Hz - our GPS rate

autonomy gravatar imageautonomy ( 2013-01-22 06:06:59 -0600 )edit

its nice that you posted back saying that this was useful

sai gravatar imagesai ( 2013-01-28 19:06:05 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2012-09-23 17:09:04 -0600

Seen: 240 times

Last updated: Oct 01 '12