Ask Your Question
0

Error while installing dependencies for RVIZ

asked 2012-08-23 00:31:32 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

Fuerte on Ubuntu 10.04

Few weeks back rviz was running on my system, but then now, it is showing some problems.

The console output:

sai@sai-desktop:~/fuerte_workspace$ rosdep install rviz
ERROR: the following packages/stacks could not have their rosdep keys resolved
to system dependencies:
rviz: Cannot locate rosdep definition for [libogre-dev]
sai@sai-desktop:~/fuerte_workspace$

roswtf doesnot show any error.

rviz is in the ROS_PACKAGE_PATH.

I will first install the dependencies for rviz, then rosmake and rosrun it.

I did what you said in the answer... it resulted in

sai@sai-desktop:~$ sudo apt-get install ros-fuerte-visualization
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  ros-fuerte-visualization: Depends: ros-fuerte-geometry (= 1.8.2-s1344793584~lucid) but it is not going to be installed
                            Depends: ros-fuerte-laser-pipeline (= 1.4.4-s1344799073~lucid) but it is not going to be installed
                            Depends: ros-fuerte-robot-model (= 1.8.1-s1344897363~lucid) but it is not going to be installed
E: Broken packages
edit retag flag offensive close merge delete

Comments

Try sudo apt-get update and maybe sudo apt-get dist-upgrade to upgrade all packages before installing ros-fuerte-visualization.

Lorenz gravatar image Lorenz  ( 2012-08-23 00:58:52 -0500 )edit

I executed both of them and they did not give any errors. Still the reos-fuerte-visualization is resulting in same error...

sai gravatar image sai  ( 2012-08-23 01:10:11 -0500 )edit
1

I have found many such dependency error when I used Fuerte with ubuntu 10.04. However, after I upgraded to Ubuntu 12.04 there were no problems and all the dependencies were properly installed. Modifying your ros package source to that of precise(12.04) in your software sources may help.

SivamPillai gravatar image SivamPillai  ( 2012-08-23 01:41:41 -0500 )edit

Thanks, I will try that and report it here...:)

sai gravatar image sai  ( 2012-08-24 07:23:05 -0500 )edit
1

Yes it worked when UBUNTU 12.04 was installed. Thank you so much for the suggestions..

sai gravatar image sai  ( 2012-08-24 23:39:02 -0500 )edit

tht sounds good :) all the best with your work :) mayb u can upvote my answer so that others feel it the most reliable comment...

SivamPillai gravatar image SivamPillai  ( 2012-08-25 01:37:24 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2012-08-23 00:46:03 -0500

Lorenz gravatar image

Normally, you install rviz debian package:

sudo apt-get install ros-fuerte-visualization

That pulls in all dependencies already, so you don't need to run rosdep or rosmake, just rosrun rviz rviz.

edit flag offensive delete link more

Comments

Yes..it worked on ubuntu 10.04 initially but later it didnt work and showed up some errors. When I installed ubuntu12.04, there were no errors..

sai gravatar image sai  ( 2012-09-02 17:28:40 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2012-08-23 00:31:32 -0500

Seen: 728 times

Last updated: Aug 23 '12