ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question
0

Rosdep failed to install python-catkin-pkg-modules on Debian buster

asked 2022-11-21 01:06:09 -0500

tunamayo gravatar image

updated 2022-11-22 00:42:55 -0500

I want to install ROS Melodic on Raspberrypi4 model B.

My environment:RaspberryPi4 model B 2GB RAM

$ uname -a
Linux raspberrypi 5.10.103-v7l+ #1529 SMP Tue Mar 8 12:24:00 GMT 2022 armv7l GNU/Linux
$ cat /etc/debian_version 
10.13

I followed the steps in this page:Installing ROS Melodic on the Raspberry Pi

An error occurred when executing the following command

rosdep install -y --from-paths src --ignore-src --rosdistro melodic -r --os=debian:buster

Sorry,Error contains Japanese characters.

Error:

executing command [sudo -H apt-get install -y python-catkin-pkg-modules]
パッケージリストを読み込んでいます... 完了
依存関係ツリーを作成しています
状態情報を読み取っています... 完了
以下のパッケージが自動でインストールされましたが、もう必要とされていません:
python3-rospkg-modules
これを削除するには 'sudo apt autoremove' を利用してください。
以下のパッケージが新たにインストールされます:
python-catkin-pkg-modules
アップグレード: 0 個、新規インストール: 1 個、削除: 0 個、保留: 0 個。
41.0 kB 中 0 B のアーカイブを取得する必要があります。
この操作後に追加で 249 kB のディスク容量が消費されます。
(データベースを読み込んでいます ... 現在 150007 個のファイルとディレクトリがインストールされています。)
.../python-catkin-pkg-modules_0.4.8-1_all.deb を展開する準備をしています ...
python-catkin-pkg-modules (0.4.8-1) を展開しています...
dpkg: アーカイブ /var/cache/apt/archives/python-catkin-pkg-modules_0.4.8-1_all.deb の処理中にエラーが発生しました (--unpack):
'/usr/lib/python2.7/dist-packages/catkin_pkg/topological_order.py' を上書きしようとしています。これはパッケージ python-catkin-pkg 0.4.10-1 にも存在します
処理中にエラーが発生しました:
/var/cache/apt/archives/python-catkin-pkg-modules_0.4.8-1_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
executing command [sudo -H apt-get install -y python-rosdep-modules]
パッケージリストを読み込んでいます... 完了
依存関係ツリーを作成しています
状態情報を読み取っています... 完了
E: パッケージ python-rosdep-modules が見つかりません
executing command [sudo -H apt-get install -y python3-rosdep-modules]
パッケージリストを読み込んでいます... 完了
依存関係ツリーを作成しています
状態情報を読み取っています... 完了
E: パッケージ python3-rosdep-modules が見つかりません
executing command [sudo -H apt-get install -y python3-rospkg]
パッケージリストを読み込んでいます... 完了
依存関係ツリーを作成しています
状態情報を読み取っています... 完了
以下のパッケージが自動でインストールされましたが、もう必要とされていません:
python-catkin-pkg python-rospkg-modules
これを削除するには 'sudo apt autoremove' を利用してください。
以下のパッケージは「削除」されます:
python-rosdep python-rosdistro python-rosinstall python-rosinstall-generator python-rospkg
以下のパッケージが新たにインストールされます:
python3-rospkg
アップグレード: 0 個、新規インストール: 1 個、削除: 5 個、保留: 0 個。
2,142 B 中 0 B のアーカイブを取得する必要があります。
この操作後に 776 kB のディスク容量が解放されます。
(データベースを読み込んでいます ... 現在 150006 個のファイルとディレクトリがインストールされています。)
python-rosdep (0.14.0-1) を削除しています ...
python-rosinstall-generator (0.1.14-1) を削除しています ...
python-rosinstall (0.7.8-2) を削除しています ...
python-rosdistro (0.7.2-1) を削除しています ...
python-rospkg (1.1.7-100) を削除しています ...
以前に未選択のパッケージ python3-rospkg を選択しています。
(データベースを読み込んでいます ... 現在 149858 個のファイルとディレクトリがインストールされています。)
.../python3-rospkg_1.1.7-100_all.deb を展開する準備をしています ...
python3-rospkg (1.1.7-100) を展開しています...
python3-rospkg (1.1.7-100) を設定しています ...
executing command [sudo -H apt-get install -y python3-catkin-pkg-modules]
パッケージリストを読み込んでいます... 完了
依存関係ツリーを作成しています
状態情報を読み取っています... 完了
以下のパッケージが自動でインストールされましたが、もう必要とされていません:
python-catkin-pkg python-rospkg-modules
これを削除するには 'sudo apt autoremove' を利用してください。
以下のパッケージが新たにインストールされます:
python3-catkin-pkg-modules
アップグレード: 0 個、新規インストール: 1 個、削除: 0 個、保留: 0 個。
41.0 kB 中 0 B のアーカイブを取得する必要があります。
この操作後に追加で 248 kB のディスク容量が消費されます。
(データベースを読み込んでいます ... 現在 149867 個のファイルとディレクトリがインストールされています。)
.../python3-catkin-pkg-modules_0.4.8-1_all.deb を展開する準備をしています ...
python3-catkin-pkg-modules (0.4.8-1) を展開しています...
dpkg: アーカイブ /var/cache/apt/archives/python3-catkin-pkg-modules_0.4.8-1_all.deb の処理中にエラーが発生しました (--unpack):
'/usr/lib/python3/dist-packages/catkin_pkg/topological_order.py' を上書きしようとしています。これはパッケージ python3-catkin-pkg 0.4.10-1 にも存在します
処理中にエラーが発生しました:
/var/cache/apt/archives/python3-catkin-pkg-modules_0.4.8-1_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
ERROR: the following rosdeps failed to install
apt: command [sudo -H apt-get install -y python-catkin-pkg-modules] failed
apt: command [sudo -H apt-get install -y python-rosdep-modules] failed
apt: command [sudo -H apt-get install -y python3-rosdep-modules] failed
apt: command [sudo -H apt-get install -y python3-catkin-pkg-modules] failed
apt: Failed to detect successful installation of [python-catkin-pkg-modules]
apt: Failed to detect successful installation of [python-rosdep-modules]
apt: Failed to detect successful installation of ...

(more)
edit retag flag offensive close merge delete

Comments

Please edit your question to include more of the error content above. This is mostly the summary and not the full error.

tfoote gravatar image tfoote  ( 2022-11-21 19:02:45 -0500 )edit

I have added the full error.

tunamayo gravatar image tunamayo  ( 2022-11-22 00:51:11 -0500 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2022-11-22 17:14:39 -0500

tfoote gravatar image

The error you're getting is due to conflicting files installed from different packages. It looks like you have very old versions of some of those packages.

There's a few things I'll flag. First is that you appear to be mixing python2 and python3 which is unexpected for melodic. By default everything should be using python2 in melodic.

Second, I see python3-catkin-pkg-modules is quite old. The instruction that you link to have an apt-get upgrade that I think you may have not executed, or your system is old enough you need to use an apt-get dist-upgrade to get coverage.

I tried it out on in a clean buster container and wasn't able to reproduce the problem. You may need to understand more about where your image is coming from or what the legacy of that system is. But the primary recommendation is to make sure that your tools are up to date before you try to install the new ones.

And secondly I would strongly recommend that you double check where the different python version is coming from and that that is something that you want to debug and deal with. It will make your experience more complicated.

edit flag offensive delete link more

Comments

I tried an apt-get and an apt-get dist-upgrade , but nothing updated.

So I reinstalled the OS and it works fine.

tunamayo gravatar image tunamayo  ( 2022-11-25 02:02:30 -0500 )edit

Yeah, it sounds like you had some conflicting packages preinstalled on your system.

tfoote gravatar image tfoote  ( 2022-11-29 14:35:42 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2022-11-21 01:06:09 -0500

Seen: 593 times

Last updated: Nov 22 '22